]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-libc-headers: sync with OE (mainly safer use of and blackfin support)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 26 Oct 2007 12:12:24 +0000 (12:12 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 26 Oct 2007 12:12:24 +0000 (12:12 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3002 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
meta/packages/linux-libc-headers/linux-libc-headers_2.6.18+2.6.19-rc1.bb
meta/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb
meta/packages/linux-libc-headers/linux-libc-headers_2.6.20.bb

index 30f57000bb25b84b55b07959a8850d9207e20896..3f5cc3a0b5ae473f1e2fbb552fa419f29fa68242 100644 (file)
@@ -1,12 +1,11 @@
-SECTION = "devel"
-DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
+require linux-libc-headers.inc
+
 HOMEPAGE = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/"
-# license note from the package: 
+# license note from the package:
 #   Linux-libc-headers are derived from linux kernel headers. For license of a
 #   particular header, check it's content, and if copyright notice isn't present,
-#   standard linux kernel license applies. 
+#   standard linux kernel license applies.
 # since we assume GPL for linux i think we can also assume it here
-LICENSE = "GPL"
 INHIBIT_DEFAULT_DEPS = "1"
 PR = "r2"
 
index 8d82f7b6620f789956c6952518ff19bf8a8dba5f..0dba90dc9705e6bf6f8cd219e7dec797550792e7 100644 (file)
@@ -1,17 +1,16 @@
-SECTION = "devel"
-DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
+require linux-libc-headers.inc
+
 # This package is derived from the original linux-libc-headers at
 #   http://ep09.pld-linux.org/~mmazur/linux-libc-headers/
-# More specifically, llh-2.6.12.0 was patched up to 2.6.16-rc6 with 
+# More specifically, llh-2.6.12.0 was patched up to 2.6.16-rc6 with
 # the official linux patches (where applicable) and then fixed up just
 # enough to build glibc-2.4. BEWARE!
 #
-# license note from the linux-libc-headers package: 
+# license note from the linux-libc-headers package:
 #   Linux-libc-headers are derived from linux kernel headers. For license of a
 #   particular header, check it's content, and if copyright notice isn't present,
-#   standard linux kernel license applies. 
+#   standard linux kernel license applies.
 # since we assume GPL for linux i think we can also assume it here
-LICENSE = "GPL"
 DEFAULT_PREFERENCE = "-1"
 INHIBIT_DEFAULT_DEPS = "1"
 PR = "r4"
index 8c6222560fa2512e35ba520ad47683adc8f93849..7cb5c4aa2d3d4ac50ebaff7a8ff96cfe4ee99dd9 100644 (file)
@@ -36,7 +36,7 @@ do_install() {
        set_arch
        install -d ${D}${includedir}
        cp -pfLR ${S}${includedir}/linux ${D}${includedir}/
-       cp -pfLR ${S}${includedir}/asm-$ARCH ${D}${includedir}/asm
+       cp -pfLR ${S}${includedir}/asm-${ARCH} ${D}${includedir}/asm
        cp -pfLR ${S}${includedir}/asm-generic ${D}${includedir}/
 }
 
@@ -45,6 +45,14 @@ do_stage () {
        install -d ${STAGING_INCDIR}
        rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
        cp -pfLR ${S}${includedir}/linux ${STAGING_INCDIR}/
-       cp -pfLR ${S}${includedir}/asm-$ARCH ${STAGING_INCDIR}/asm
+       cp -pfLR ${S}${includedir}/asm-${ARCH} ${STAGING_INCDIR}/asm
        cp -pfLR ${S}${includedir}/asm-generic ${STAGING_INCDIR}/
 }
+
+do_stage_append_nylon () {
+       cp -pPR include/asm-${ARCH}/* ${STAGING_INCDIR}/asm/
+       cp -pPR include/asm-${ARCH}/* ${CROSS_DIR}/${TARGET_SYS}/include/asm/
+       cp -pPR include/linux/* ${STAGING_INCDIR}/linux/
+       cp -pPR include/linux/* ${CROSS_DIR}/${TARGET_SYS}/include/linux/
+}
+
index 33cbb4ad28d23e038005d89de1db34bca99bcb88..3abf26f4ff89dd614eac9c1ec9da9b505f9cfc63 100644 (file)
@@ -30,7 +30,7 @@ set_arch() {
 
 do_configure() {
        set_arch
-       oe_runmake allnoconfig ARCH=$ARCH
+       oe_runmake allnoconfig ARCH=${ARCH}
 }
 
 do_compile () {
@@ -38,7 +38,7 @@ do_compile () {
 
 do_install() {
        set_arch
-       oe_runmake headers_install INSTALL_HDR_PATH=${D}/usr ARCH=$ARCH
+       oe_runmake headers_install INSTALL_HDR_PATH=${D}/usr ARCH=${ARCH}
 }
 
 do_install_append_arm() {
@@ -51,8 +51,8 @@ do_stage () {
        set_arch
        rm -rf ${STAGE_TEMP}
        mkdir -p ${STAGE_TEMP}
-       oe_runmake headers_install INSTALL_HDR_PATH=${STAGE_TEMP}/usr ARCH=$ARCH
-       if [ "$ARCH" = "arm" ]; then
+       oe_runmake headers_install INSTALL_HDR_PATH=${STAGE_TEMP}/usr ARCH=${ARCH}
+       if [ "${ARCH}" == "arm" ]; then
                cp include/asm-arm/procinfo.h ${STAGE_TEMP}${includedir}/asm
        fi
        install -d ${STAGING_INCDIR}
@@ -60,4 +60,18 @@ do_stage () {
        cp -pfLR ${STAGE_TEMP}${includedir}/linux ${STAGING_INCDIR}/
        cp -pfLR ${STAGE_TEMP}${includedir}/asm ${STAGING_INCDIR}/
        cp -pfLR ${STAGE_TEMP}${includedir}/asm-generic ${STAGING_INCDIR}/
+       # Add UTS_RELEASE to version.h. UTS_RELEASE was moved from version.h to 
+       # utsrelease.h in order to avoid recompiling a kernel every time a localversion
+       # changed. Since the our headers are static and we're not compiling an 
+       # actual kernel, re-adding UTS_RELEASE does't hurt, and it allows uclibc to 
+       # compile with kernel headers that work with EABI on ARM
+       echo '#define UTS_RELEASE "2.6.18"' >> ${STAGING_INCDIR}/linux/version.h
 }
+
+do_stage_append_nylon () {
+       cp -pPR include/asm-${ARCH}/* ${STAGING_INCDIR}/asm/
+       cp -pPR include/asm-${ARCH}/* ${CROSS_DIR}/${TARGET_SYS}/include/asm/
+       cp -pPR include/linux/* ${STAGING_INCDIR}/linux/
+       cp -pPR include/linux/* ${CROSS_DIR}/${TARGET_SYS}/include/linux/
+}
+
index 3f5607684a430ea403107a720d86538531d3f05c..0b6112884e6f1657712adf051aaced0b1b1afe64 100644 (file)
@@ -25,6 +25,8 @@ set_arch() {
                sparc64*) ARCH=sparc64 ;;
                sparc*)   ARCH=sparc ;;
                x86_64*)  ARCH=x86_64 ;;
+               avr32*)   ARCH=avr32 ;;
+                bfin*)    ARCH=blackfin ;;
        esac
 }