]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: Fix Dependency and compatible machines
authorSaul Wold <sgw@linux.intel.com>
Sun, 15 May 2011 01:44:36 +0000 (18:44 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 18 May 2011 13:28:10 +0000 (14:28 +0100)
add DEFAULT_PREFERENCE = "-1" to disable git recipe
Added libx11 for GL support to DEPENDS
Use BROKEN to disable qemuarm and qemumips world build of qemu target

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/qemu/qemu.inc
meta/recipes-devtools/qemu/qemu_0.14.0.bb
meta/recipes-devtools/qemu/qemu_git.bb

index 49bcf8e93911abed37847e9fb0ef9d1af848913f..18073eb4fca7115fb62dc8746cb9a147bb01f63c 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "open source processor emulator"
 HOMEPAGE = "http://qemu.org"
 LICENSE = "GPLv2 & LGPLv2.1"
-DEPENDS = "zlib alsa-lib"
+DEPENDS = "zlib alsa-lib qemugl"
 
 # QEMU_TARGETS is overridable variable
 QEMU_TARGETS ?= "arm i386 mips mipsel mips64 mips64el ppc sh4 x86_64"
@@ -16,7 +16,6 @@ EXTRA_OECONF += "--target-list=${@get_qemu_target_list(d)} --disable-werror --di
 
 #EXTRA_OECONF += "--disable-sdl"
 
-COMPATIBLE_MACHINES = "qemux86 qemuppc"
 
 inherit autotools
 
@@ -43,9 +42,14 @@ do_configure() {
     chmod a+x ${S}/target-i386/beginend_funcs.sh
 }
 
-SRC_URI_append_virtclass-nativesdk = " file://glflags.patch;patch=1"
+SRC_URI_append_virtclass-nativesdk = " file://glflags.patch"
+DEPENDS_virtclass-native = "zlib-native alsa-lib-native"
 DEPENDS_virtclass-nativesdk = "zlib-nativesdk libsdl-nativesdk qemugl-nativesdk"
 RDEPENDS_virtclass-nativesdk = "libsdl-nativesdk"
 EXTRA_OECONF_virtclass-nativesdk += "--target-list=${@get_qemu_target_list(d)} --disable-werror --disable-vnc-tls"
 
 BBCLASSEXTEND = "native nativesdk"
+
+# Qemu target will not build in world build for ARM or Mips
+BROKEN_qemuarm = "1"
+BROKEN_qemumips = "1"
index f0a4beae1cf30cd07aee88d99ab06c3d22eff039..ccf5ee4f2d162be741f236e6dcf62576611937ce 100644 (file)
@@ -3,7 +3,7 @@ require qemu.inc
 LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
                     file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
 
-PR = "r1"
+PR = "r2"
 
 FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
 FILESDIR = "${WORKDIR}"
index 2d6a8bdd650881daf1d07b19e8d8ccf85a8a5048..59fc7f13964fad718cb655a49c9292b84b9b987b 100644 (file)
@@ -5,8 +5,8 @@ SRCREV = "56a60dd6d619877e9957ba06b92d2f276e3c229d"
 LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
                     file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
 
-PV = "0.14"
-PR = "r0"
+PV = "0.14.0"
+PR = "r1"
 
 FILESPATH = "${FILE_DIRNAME}/qemu-${PV}/:${FILE_DIRNAME}/qemu-git/"
 FILESDIR = "${WORKDIR}"
@@ -23,3 +23,6 @@ SRC_URI = "\
 
 S = "${WORKDIR}/git"
 
+DEFAULT_PREFERENCE = "-1"
+
+