]> code.ossystems Code Review - openembedded-core.git/commitdiff
buildtools-tarball.bb: 32bit tools need pseudo 32bit library
authorJuro Bystricky <juro.bystricky@intel.com>
Thu, 3 Dec 2015 23:09:55 +0000 (15:09 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 12 Dec 2015 23:31:41 +0000 (23:31 +0000)
"pseudo" does not build 32 bit library by default on 64 bit host, but the
32 bit library is needed when using 32 bit development tools (buildtools-tarball)
running on a 64 bit host. Building of the library can be forced if the
environment variable NO32LIBS is set to "0".

Hence for 32 bit buildtools we export the environment variable NO32LIBS="0"
and NO32LIBS is also added into BB_ENV_EXTRAWHITE (if not already there).

[YOCTO#8581]

Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/meta/buildtools-tarball.bb

index 840434ccd20cd9e54ac2db4239568fb0ae1577d5..8ad4e91ae403add87657dd49826f73607c4aeb72 100644 (file)
@@ -56,4 +56,10 @@ create_sdk_files_append () {
        toolchain_create_sdk_version ${SDK_OUTPUT}/${SDKPATH}/version-${SDK_SYS}
 
        echo 'export GIT_SSL_CAINFO="${SDKPATHNATIVE}${sysconfdir}/ssl/certs/ca-certificates.crt"' >>$script
+
+       if [ ${SDKMACHINE} = "i686" ]; then
+               echo 'export NO32LIBS="0"' >>$script
+               echo 'echo "$BB_ENV_EXTRAWHITE" | grep -q "NO32LIBS"' >>$script
+               echo '[ $? != 0 ] && export BB_ENV_EXTRAWHITE="NO32LIBS $BB_ENV_EXTRAWHITE"' >>$script
+       fi
 }