]> code.ossystems Code Review - openembedded-core.git/commitdiff
dropbear: don't override DISTRO_TYPE if it is already set
authorKoen Kooi <koen@dominion.thruhere.net>
Mon, 25 Jul 2011 08:08:59 +0000 (10:08 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 27 Jul 2011 10:54:48 +0000 (11:54 +0100)
The long term solution is to remove the IMAGE_FEATURE check since images are not allowed to influence recipe compile options.

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
meta/recipes-core/dropbear/dropbear.inc
meta/recipes-core/dropbear/dropbear_0.52.bb

index 1b51e1a5881256f1697d0841c31b38a69a226674..526a5a045d92f0b324fee51e18bbdd642d548b0c 100644 (file)
@@ -29,7 +29,7 @@ SBINCOMMANDS = "dropbear dropbearkey dropbearconvert"
 BINCOMMANDS = "dbclient ssh scp"
 EXTRA_OEMAKE = 'MULTI=1 SCPPROGRESS=1 PROGRAMS="${SBINCOMMANDS} ${BINCOMMANDS}"'
 
-DISTRO_TYPE = "${@base_contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}"
+DISTRO_TYPE ?= "${@base_contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}"
 
 do_debug_patch() {
        if [ "${DISTRO_TYPE}" = "debug" ]; then
index 78d6cf1c0b318b1c53c682e413483f7ea1844368..4013c650747c28ac67c2c374d1119ab888752f2c 100644 (file)
@@ -3,4 +3,4 @@ require dropbear.inc
 SRC_URI[md5sum] = "1c69ec674481d7745452f68f2ea5597e"
 SRC_URI[sha256sum] = "e3a2ca49ed85ce562240c0ac06e2f72826d7e52a83e80d91c067c8b97bf5c108"
 
-PR = "r2"
+PR = "r3"