]> code.ossystems Code Review - openembedded-core.git/commitdiff
pseudo: Upgrade pseudo and correct problems
authorMark Hatle <mhatle@windriver.com>
Fri, 6 Aug 2010 18:40:55 +0000 (11:40 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 12 Aug 2010 14:47:02 +0000 (15:47 +0100)
Fix an issue where pseudo could try to compile incorrectly on an
x86_64 host system.  Now it verifies that it should be trying to build
a 32-bit library, and if so the necessary prereqs are available.

Also uprev to the latest version of pseudo changes to enable wrapping
of execl, local variable storage and misc fixes.

Signed-off-by: Mark Hatle <mhatle@windriver.com>
meta/classes/sanity.bbclass
meta/conf/distro/include/poky-default-revisions.inc
meta/packages/pseudo/pseudo_git.bb

index 31b8dd2b07d23440d05b6e51458b10eadae43d26..a595224a7f80fde8fe9a0629c64a5f358529e2fe 100644 (file)
@@ -143,6 +143,11 @@ def check_sanity(e):
        if data.getVar('SDK_ARCH', e.data, True) == 'i686':
                messages = messages + '"Please set SDKMACHINE to i586. It is currently defaulting to the build machine architecture of i686 and this is known to have issues (see local.conf).\n'
 
+       nolibs = data.getVar('NO32LIBS', e.data, True)
+       if not nolibs:
+               if os.path.exists('/lib/libc.so.6') and not os.path.exists('/usr/include/gnu/stubs-32.h'):
+                       messages = messages + "You have a 32-bit libc, but no 32-bit headers.  You must install the 32-bit libc headers.\n"
+
        #
        # Check that TMPDIR hasn't changed location since the last time we were run
        #
index fe3e8bbf08cbb76fd305629d5190f089264ca99a..190296abf3b88f2e4b6bdf512471d4daa48504a3 100644 (file)
@@ -110,7 +110,7 @@ PRELINKSRCREV ??= "909470ee441237563d6236c505cb2d02ddc48704"
 SRCREV_pn-prelink ??= "${PRELINKSRCREV}"
 SRCREV_pn-prelink-native ??= "${PRELINKSRCREV}"
 SRCREV_pn-psplash ??= "424"
-PSEUDOSRCREV ??= "551bf567c171c9f6f475f02de80e35df9563dce7"
+PSEUDOSRCREV ??= "5d027f78a6e677e9272a17555a83124026e6fb08"
 SRCREV_pn-pseudo ??= "${PSEUDOSRCREV}"
 SRCREV_pn-pseudo-native ??= "${PSEUDOSRCREV}"
 QEMUSRCREV ??= "72bb3c7571226af13cfe9eec020a56add3d30a70"
index d393967cebe59f1a5f4a59e8e1dada438e74eb54..eac398ed12d9537155452d40c65a87df324b09df 100644 (file)
@@ -6,7 +6,7 @@ LICENSE = "LGPL2.1"
 DEPENDS = "sqlite3"
 
 PV = "0.0+git${SRCPV}"
-PR = "r12"
+PR = "r13"
 
 SRC_URI = "git://github.com/wrpseudo/pseudo.git;protocol=git \
            file://static_sqlite.patch"
@@ -26,8 +26,8 @@ do_compile () {
        if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" ]; then
                # We need the 32-bit libpseudo on a 64-bit machine...
                ./configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=32
-               oe_runmake 'CFLAGS=-m32' 'LIB=lib/pseudo/lib'
-               # prevent it from removing the lib, but keep everything else
+               oe_runmake 'CFLAGS=-m32' 'LIB=lib/pseudo/lib' libpseudo
+               # prevent it from removing the lib, but remove everything else
                make 'LIB=foo' distclean 
        fi
        ${S}/configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=${SITEINFO_BITS}