]> code.ossystems Code Review - openembedded-core.git/commitdiff
handbook: use XML catalogues to make building work on all(?) distros
authorJoshua Lock <josh@linux.intel.com>
Fri, 4 Jun 2010 13:48:34 +0000 (14:48 +0100)
committerJoshua Lock <josh@linux.intel.com>
Fri, 4 Jun 2010 19:02:06 +0000 (20:02 +0100)
Thanks to Damien's pointers we should now be able to generate the handbook
regardless of host distro

Signed-off-by: Joshua Lock <josh@linux.intel.com>
handbook/Makefile
handbook/poky-doc-tools/Makefile.am
handbook/poky-doc-tools/autogen.sh
handbook/poky-doc-tools/common/poky-db-pdf.xsl
handbook/poky-doc-tools/poky-docbook-to-pdf.in

index 01353b11afe731c1217c721e490697fcbe10987a..5dff1a87428101824770fe14de3f864e2619f6ef 100644 (file)
@@ -1,7 +1,6 @@
 all: html pdf tarball
 
 pdf:
-
        ./poky-doc-tools/poky-docbook-to-pdf poky-handbook.xml
        ./poky-doc-tools/poky-docbook-to-pdf bsp-guide.xml
 #       -- old way --
@@ -11,12 +10,17 @@ XSLTOPTS = --stringparam html.stylesheet style.css \
            --stringparam  chapter.autolabel 1 \
            --stringparam  appendix.autolabel 1 \
            --stringparam  section.autolabel 1
-XSLTOPTS2 = --xinclude /usr/share/xml/docbook/stylesheet/nwalsh/html/docbook.xsl
+
+##
+# These URI should be rewritten by your distribution's xml catalog to
+# match your localy installed XSL stylesheets.
+XSL_BASE_URI  = http://docbook.sourceforge.net/release/xsl/current
+XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
 
 html:
 #       See http://www.sagehill.net/docbookxsl/HtmlOutput.html 
-       xsltproc $(XSLTOPTS) -o poky-handbook.html $(XSLTOPTS2) poky-handbook.xml
-       xsltproc $(XSLTOPTS) -o bsp-guide.html $(XSLTOPTS2) bsp-guide.xml
+       xsltproc $(XSLTOPTS) -o poky-handbook.html $(XSL_XHTML_URI) poky-handbook.xml
+       xsltproc $(XSLTOPTS) -o bsp-guide.html $(XSL_XHTML_URI) bsp-guide.xml
 #       -- old way --
 #      xmlto xhtml-nochunks poky-handbook.xml
 
index ca92ae714c87ac8d6c06e4c01cf61df3f7e18ad4..4533cd832d6f1423af20bcb5f2712a8f93c775da 100644 (file)
@@ -7,7 +7,13 @@ bin_SCRIPTS = poky-docbook-to-pdf
 edit = sed \
         -e 's,@datadir\@,$(pkgdatadir),g' \
         -e 's,@prefix\@,$(prefix),g'      \
-        -e 's,@version\@,@VERSION@,g'      
+        -e 's,@version\@,@VERSION@,g'
+
+##
+# These URI should be rewritten by your distribution's xml catalog to
+# match your localy installed XSL stylesheets.
+XSL_BASE_URI="http://docbook.sourceforge.net/release/xsl/current"
+XSL_TEMPLATE_URI = $(XSL_BASE_URI)/template/titlepage.xsl
 
 poky-docbook-to-pdf: poky-docbook-to-pdf.in
        rm -f poky-docbook-to-pdf
index 5daa9356086454cd343df45c89cefe4daf085b33..d68a142b839d02016b69adfceb9e741355813c57 100755 (executable)
@@ -1,3 +1,3 @@
 #! /bin/sh
 autoreconf -v --install || exit 1
-./configure --enable-maintainer-mode --enable-debug "$@"
+./configure "$@"
index 302e66f64046b0cd11c4c04bb331e2478e0462f7..3dd065a57e64e5690544a6a75e667ab06a2d80b6 100644 (file)
@@ -1,7 +1,7 @@
 <?xml version='1.0'?>
 <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns="http://www.w3.org/1999/xhtml" xmlns:fo="http://www.w3.org/1999/XSL/Format" version="1.0">
   
-  <xsl:import href="file:///usr/share/xml/docbook/stylesheet/nwalsh/fo/docbook.xsl"/>
+  <xsl:import href="http://docbook.sourceforge.net/release/xsl/current/fo/docbook.xsl" />
 
   <!-- check project-plan.sh for how this is generated, needed to tweak 
        the cover page     
index cc999ab995c9df88c2d12ee89c5eca8c592283d5..b56aee49545e0ac13a3da138f1f704d7cb153926 100644 (file)
@@ -18,9 +18,14 @@ BASENAME=`basename $1 .xml` || exit 1
 FO="$BASENAME.fo" 
 PDF="$BASENAME.pdf"
 
+##
+# These URI should be rewritten by your distribution's xml catalog to
+# match your localy installed XSL stylesheets.
+XSL_BASE_URI="http://docbook.sourceforge.net/release/xsl/current"
+
 xsltproc -o /tmp/titlepage.xsl                                           \
         --xinclude                                                      \
-         /usr/share/xml/docbook/stylesheet/nwalsh/template/titlepage.xsl \
+         $XSL_BASE_URI/template/titlepage.xsl \
          @datadir@/common/titlepage.templates.xml || exit 1
 
 xsltproc --xinclude                    \