]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: Ensure native binaries are correctly wrapped
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 30 Jan 2013 14:46:00 +0000 (14:46 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 30 Jan 2013 14:47:21 +0000 (14:47 +0000)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rpm/rpm_5.4.9.bb

index 6977131a28392260695d181bb091edbc05033a96..881b960a0f2195d281e983a27a0bd2308f12eac7 100644 (file)
@@ -470,7 +470,7 @@ do_install_append_class-native() {
                RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
 
        for rpm_binary in ${D}/${libdir}/rpm/bin/rpm*; do
-               create_wrapper $rpm_binary
+               create_wrapper $rpm_binary \
                        RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
                        RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
                        RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale