]> code.ossystems Code Review - openembedded-core.git/commitdiff
lrzsz: use update-alternatives (from OE)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 26 Oct 2007 11:39:18 +0000 (11:39 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 26 Oct 2007 11:39:18 +0000 (11:39 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3000 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/lrzsz/lrzsz_0.12.20.bb

index 8110661ac1dbc9e4b35d79d1698a33315d5a2f5c..0a194f9a0534b91f30d2eb55c5948596fef63ab5 100644 (file)
@@ -3,7 +3,7 @@ SECTION = "console/network"
 PRIORITY = "standard"
 DESCRIPTION = "Tools for zmodem/xmodem/ymodem file transfer"
 DEPENDS = ""
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "http://www.ohse.de/uwe/releases/lrzsz-${PV}.tar.gz \
           file://autotools.patch;patch=1 \
@@ -15,10 +15,16 @@ inherit autotools gettext
 do_install() {
        install -d ${D}${bindir}/
        install -m 0755 src/lrz src/lsz ${D}${bindir}/
-       ln -sf ./lrz ${D}${bindir}/rz
-       ln -sf ./lrz ${D}${bindir}/rx
-       ln -sf ./lrz ${D}${bindir}/rb
-       ln -sf ./lsz ${D}${bindir}/sz
-       ln -sf ./lsz ${D}${bindir}/sx
-       ln -sf ./lsz ${D}${bindir}/sb
 }
+
+pkg_postinst() {
+       for util in rz rx rb sz sx sb; do
+               update-alternatives --install ${bindir}/$util $util lrz 100
+       done
+}
+
+pkg_postrm() {
+       for util in rz rx rb sz sx sb; do
+               update-alternatives --remove $util ${bindir}/lrz
+       done
+}
\ No newline at end of file