]> code.ossystems Code Review - openembedded-core.git/commitdiff
gobject-introspection: add a patch to fix a build race
authorAlexander Kanavin <alex.kanavin@gmail.com>
Wed, 17 Jun 2020 10:15:52 +0000 (12:15 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 17 Jun 2020 15:31:48 +0000 (16:31 +0100)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-gnome/gobject-introspection/gobject-introspection/0001-gir-add-a-dependency-for-g-ir-compiler-for-building-.patch [new file with mode: 0644]
meta/recipes-gnome/gobject-introspection/gobject-introspection_1.64.1.bb

diff --git a/meta/recipes-gnome/gobject-introspection/gobject-introspection/0001-gir-add-a-dependency-for-g-ir-compiler-for-building-.patch b/meta/recipes-gnome/gobject-introspection/gobject-introspection/0001-gir-add-a-dependency-for-g-ir-compiler-for-building-.patch
new file mode 100644 (file)
index 0000000..adb357b
--- /dev/null
@@ -0,0 +1,33 @@
+From 56ba5656258b82dbc069ab3a61e597c931a16a83 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Wed, 17 Jun 2020 11:43:16 +0200
+Subject: [PATCH] gir: add a dependency for g-ir-compiler for building .girs
+
+meson inserts the dependency if the compiler is used directly, but
+fails to do so if the compiler is run through a wrapper. This leads
+to build race errors between building the compiler and using it.
+
+Fix provided by Quentin Schulz <quentin.schulz@streamunlimited.com>
+
+Upstream-Status: Accepted [https://gitlab.gnome.org/GNOME/gobject-introspection/-/merge_requests/228]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ gir/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gir/meson.build b/gir/meson.build
+index b37fdb81..557e5517 100644
+--- a/gir/meson.build
++++ b/gir/meson.build
+@@ -448,7 +448,7 @@ foreach gir : gir_files
+   typelibs += custom_target('generate-typelib-@0@'.format(gir).underscorify(),
+     input: gir,
+     output: '@BASENAME@.typelib',
+-    depends: [gobject_gir, ],
++    depends: [gobject_gir, gircompiler, ],
+     command: gircompiler_command,
+     install: true,
+     install_dir: typelibdir,
+-- 
+2.27.0
+
index 9dfb55e055c1fcb034823961017dd44f3550f8f5..7eefdd3e27a33ba38b4ea6682a691021fdeda5c1 100644 (file)
@@ -15,6 +15,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c434e8128a68bedd59b80b2ac1eb1c4a \
 
 SRC_URI = "${GNOME_MIRROR}/${BPN}/${@oe.utils.trim_version("${PV}", 2)}/${BPN}-${PV}.tar.xz \
            file://0001-giscanner-ignore-error-return-codes-from-ldd-wrapper.patch \
+           file://0001-gir-add-a-dependency-for-g-ir-compiler-for-building-.patch \
            "
 
 SRC_URI[md5sum] = "3419dfd086efcf83768e0579ab6abd2b"