]> code.ossystems Code Review - openembedded-core.git/commitdiff
jpeg: Convert to BBCLASSEXTEND (and drop unneeded custom staging function
authorRichard Purdie <rpurdie@linux.intel.com>
Thu, 5 Nov 2009 17:10:56 +0000 (17:10 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 13 Nov 2009 12:15:25 +0000 (12:15 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/jpeg/jpeg-native_6b.bb [deleted file]
meta/packages/jpeg/jpeg_6b.bb

diff --git a/meta/packages/jpeg/jpeg-native_6b.bb b/meta/packages/jpeg/jpeg-native_6b.bb
deleted file mode 100644 (file)
index 2591a7a..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-SECTION = "libs"
-require jpeg_${PV}.bb
-inherit native
-DEPENDS = ""
-
-do_stage() {
-        install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h
-        install -m 644 jpeglib.h ${STAGING_INCDIR}/jpeglib.h
-        install -m 644 jmorecfg.h ${STAGING_INCDIR}/jmorecfg.h
-        install -m 644 jerror.h ${STAGING_INCDIR}/jerror.h
-        install -m 644 jpegint.h ${STAGING_INCDIR}/jpegint.h
-        oe_libinstall -so libjpeg ${STAGING_LIBDIR}
-}
index d64fb0996ab53593c214f4021b7c4e24337dd335..ea05c6d344de69251b1c18eee471bdf610b0c0cd 100644 (file)
@@ -4,8 +4,9 @@ SECTION = "libs"
 PRIORITY = "required"
 
 DEPENDS = "libtool-cross"
+DEPENDS_virtclass-native = "libtool-native"
 
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
           file://debian.patch;patch=1 \
@@ -25,15 +26,6 @@ do_configure_prepend () {
        rm -f ${S}/ltmain.sh
 }
 
-do_stage() {
-       install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h
-       install -m 644 jpeglib.h ${STAGING_INCDIR}/jpeglib.h
-       install -m 644 jmorecfg.h ${STAGING_INCDIR}/jmorecfg.h
-       install -m 644 jerror.h ${STAGING_INCDIR}/jerror.h
-       install -m 644 jpegint.h ${STAGING_INCDIR}/jpegint.h
-       oe_libinstall -so libjpeg ${STAGING_LIBDIR}
-}
-
 do_install() {
        install -d ${D}${bindir} ${D}${includedir} \
                   ${D}${mandir}/man1 ${D}${libdir}
@@ -43,4 +35,4 @@ do_install() {
 PACKAGES =+            "jpeg-tools "
 FILES_jpeg-tools =     "${bindir}/*"
 
-
+BBCLASSEXTEND = "native"