]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: Fix re-execution problem due to patching configure and configure.in
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 16 Apr 2012 09:47:56 +0000 (10:47 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 16 Apr 2012 11:44:36 +0000 (12:44 +0100)
There was a patch patching both configure and configure.in. Since the recipes
all autoreconf, this is pointless and means subsequent patch tasks fail.

The fix is to only patch configure.in.

[YOCTO #2194]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python-native/sys_platform_is_now_always_linux2.patch
meta/recipes-devtools/python/python-native_2.7.2.bb
meta/recipes-devtools/python/python_2.7.2.bb

index ed529366c5cfe39af01f9384ee6b7bfbad6922ea..1cb8fea50f3dc487c38f90d343e869fdceb24b49 100644 (file)
@@ -14,17 +14,6 @@ Issue #12326: sys.platform is now always 'linux2' on Linux
 
 Even if Python is compiled on Linux 3.
 
-diff --git a/configure b/configure
---- a/configure
-+++ b/configure
-@@ -2995,6 +2995,7 @@ then
-       MACHDEP="$ac_md_system$ac_md_release"
-       case $MACHDEP in
-+      linux*) MACHDEP="linux2";;
-       cygwin*) MACHDEP="cygwin";;
-       darwin*) MACHDEP="darwin";;
-       atheos*) MACHDEP="atheos";;
 diff --git a/configure.in b/configure.in
 --- a/configure.in
 +++ b/configure.in
index b00e2fcc3e1b23dd8d8ce700f55f6ee465117b78..175f31d94e1da66ff88c8013e5a8a008b2805d89 100644 (file)
@@ -1,6 +1,6 @@
 require python.inc
 DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native"
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.4"
 
 SRC_URI += "file://04-default-is-optimized.patch \
            file://05-enable-ctypes-cross-build.patch \
index 0a1708a57e2c295c0851d2e7347dff664a331473..95e17a83d6cef0e8d70bd28a09b0dd9a9c1198ae 100644 (file)
@@ -1,6 +1,6 @@
 require python.inc
 DEPENDS = "python-native bzip2 db gdbm openssl readline sqlite3 zlib"
-PR = "${INC_PR}.11"
+PR = "${INC_PR}.12"
 
 DISTRO_SRC_URI ?= "file://sitecustomize.py"
 DISTRO_SRC_URI_linuxstdbase = ""