]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-wrs: allow optional features via KERNEL_FEATURES variable
authorBruce Ashfield <bruce.ashfield@windriver.com>
Sun, 17 Oct 2010 05:14:11 +0000 (01:14 -0400)
committerBruce Ashfield <bruce.ashfield@windriver.com>
Mon, 18 Oct 2010 05:17:46 +0000 (01:17 -0400)
Fixes [BUGID #199]

Reinstate the ability to specify optional/additional kernel features
when updating the tree.

This is done via the variable KERNEL_FEATURES which specifies
a list of features to be appended to the current branch and
config. These features are part of the wrs_meta branch in the
kernel repository and hence are self contained within the
kernel tree waiting to be activated. This saves multiple
branches simply to allow a machine to have many profiles.

The kernel patching/configuration phases will locate these
features and add them to the meta_series, which in turn
modifies the tree.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/recipes-kernel/linux/linux-wrs_git.bb

index 2459b79c89edf7aeec6631aefeaa7a474ac0845b..763eaf15595643aa8f50a937847d0a2d586e5df2 100644 (file)
@@ -49,8 +49,11 @@ do_patch() {
                exit 1
        fi
 
-       # updates or generates the target description
-       updateme ${ARCH} ${WORKDIR}
+        # updates or generates the target description
+       if [ -n "${KERNEL_FEATURES}" ]; then
+              addon_features="--features ${KERNEL_FEATURES}"
+       fi
+       updateme ${addon_features} ${ARCH} ${WORKDIR}
        if [ $? -ne 0 ]; then
                echo "ERROR. Could not update ${WRMACHINE}-${LINUX_KERNEL_TYPE}"
                exit 1