]> code.ossystems Code Review - openembedded-core.git/commitdiff
mdadm: add -Wno-error to DEBUG_OPTIMIZATION
authorChangqing Li <changqing.li@windriver.com>
Fri, 22 Mar 2019 03:57:48 +0000 (11:57 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 25 Mar 2019 11:56:52 +0000 (11:56 +0000)
when compile with DEBUG_OPTIMIZATION(-Og), compile failed with below
error, fix by add -Wno-error:

[snip]
| Incremental.c: In function 'Incremental_container':
| Incremental.c:1593:3: error: 'mdfd' may be used uninitialized in this function [-Werror=maybe-uninitialized]
| close(mdfd);
| ^~~~~~~~~~~

[snip]
super-intel.c: In function 'apply_takeover_update':
| super-intel.c:9615:15: error: '%d' directive writing between 1 and 11 bytes into a region of size 7 [-Werror=format-overflow=]
| " MISSING_%d", du->index);
| ^~
...

Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/mdadm/mdadm_4.1.bb

index 6b32f08abee1e1de2cb12ab7e4a567dee26d9095..9862a38dc3e7caa500e8518ff12dd9c1b68b6d9b 100644 (file)
@@ -41,6 +41,8 @@ CFLAGS_append_mipsarchn32 = ' -D__SANE_USERSPACE_TYPES__'
 
 EXTRA_OEMAKE = 'CHECK_RUN_DIR=0 CXFLAGS="${CFLAGS}"'
 
+DEBUG_OPTIMIZATION_append = " -Wno-error"
+
 do_compile() {
        # Point to right sbindir
        sed -i -e "s;BINDIR  = /sbin;BINDIR = $base_sbindir;" -e "s;UDEVDIR = /lib;UDEVDIR = $nonarch_base_libdir;" ${S}/Makefile