]> code.ossystems Code Review - openembedded-core.git/commitdiff
nasm: Fix aclocal
authorMark Hatle <mark.hatle@windriver.com>
Tue, 21 Jun 2011 00:02:40 +0000 (19:02 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 23 Jun 2011 10:54:52 +0000 (11:54 +0100)
The mv of aclocal.m4 can only occur once, or it will fail.  On a re-run of
configure this will fail.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-devtools/nasm/nasm_2.07.bb

index 69e3b7bfb4cfc2a409098c0ceb3f86e04bc37bd7..9b75496f95ed1458823593b0ea87b3a01244a730 100644 (file)
@@ -4,7 +4,7 @@ LICENSE = "BSD-2-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=d89d124974e487e5d64da6f1cd8acfbb"
 COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/nasm/nasm-${PV}.tar.bz2 "
 
@@ -13,10 +13,12 @@ SRC_URI[sha256sum] = "ac70ee451c73d742c9ff830502e5f8b1f648b2abffa8fd00944243283b
 
 inherit autotools
 
-do_configure_prepend () {
+do_patch_fixaclocal () {
        mv aclocal.m4 acinclude.m4
 }
 
+addtask do_patch_fixaclocal after do_patch before do_configure
+
 do_install() {
        install -d ${D}${bindir}
        install -d ${D}${mandir}/man1