]> code.ossystems Code Review - openembedded-core.git/commitdiff
Error more pleasantly when trying to use python2.4
authorChris Larson <chris_larson@mentor.com>
Fri, 3 Dec 2010 17:15:04 +0000 (12:15 -0500)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 4 Jan 2011 14:46:46 +0000 (14:46 +0000)
(Bitbake rev: 57402ee727c8c1d8f5017534fb0f5e0b20aaaa5b)

Signed-off-by: Chris Larson <chris_larson@mentor.com>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
bitbake/bin/bitbake

index 82121306838a0892f7b953e3e8749975288cdd39..1dbaf96b41abc6afd8c9dadd9ede46e21511a28d 100755 (executable)
@@ -210,16 +210,17 @@ Default BBFILES are the .bb files in the current directory.""")
         ui = "knotty"
 
     try:
-        # Dynamically load the UI based on the ui name. Although we
-        # suggest a fixed set this allows you to have flexibility in which
-        # ones are available.
-        uimodule = __import__("bb.ui", fromlist = [ui])
-        ui_init = getattr(uimodule, ui).init
-    except AttributeError:
-        print("FATAL: Invalid user interface '%s' specified. " % ui)
-        print("Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'.")
-    else:
-        return_value = server.BitbakeUILauch().launch(serverinfo, ui_init, serverConnection.connection, serverConnection.events)
+        try:
+            # Dynamically load the UI based on the ui name. Although we
+            # suggest a fixed set this allows you to have flexibility in which
+            # ones are available.
+            uimodule = __import__("bb.ui", fromlist = [ui])
+            ui_init = getattr(uimodule, ui).init
+        except AttributeError:
+            print("FATAL: Invalid user interface '%s' specified. " % ui)
+            print("Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'.")
+        else:
+            return_value = server.BitbakeUILauch().launch(serverinfo, ui_init, serverConnection.connection, serverConnection.events)
     finally:
         serverConnection.terminate()