]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: add .pl, pm, pod, sh files to SSTATE_SCANE_FILES
authorSaul Wold <sgw@linux.intel.com>
Thu, 15 Dec 2011 00:07:12 +0000 (16:07 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 15 Dec 2011 14:34:56 +0000 (14:34 +0000)
This fixes problems where hardcoded paths in the file were incorrect
during sstate reusage of the task output.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/perl/perl_5.14.2.bb

index 5efe249c9f908a0ad09001c10bac3a11eae1d4a9..0abefe415020cc4f6a66cb6ea4f2f05b360766a7 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
 # We need gnugrep (for -I)
 DEPENDS = "virtual/db grep-native"
 DEPENDS += "gdbm zlib"
-PR = "r1"
+PR = "r2"
 
 # 5.10.1 has Module::Build built-in
 PROVIDES += "libmodule-build-perl"
@@ -302,3 +302,6 @@ RPROVIDES_perl-lib = "perl-lib"
 require perl-rdepends_${PV}.inc
 require perl-rprovides.inc
 require perl-rprovides_${PV}.inc
+
+SSTATE_SCAN_FILES += "*.pm *.pod *.h *.pl *.sh"
+