]> code.ossystems Code Review - openembedded-core.git/commitdiff
help2man: rewrite recipe
authorRoss Burton <ross@burtonini.com>
Fri, 4 Sep 2020 15:42:36 +0000 (16:42 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 5 Sep 2020 21:18:12 +0000 (22:18 +0100)
This recipe was originally explicitly minimal because it was needed to
bootstrap autotools, but that isn't the case anymore.

Instead of being explicitly native, use BBCLASSEXTEND.

No need to explicitly depend on autoconf-native automake-native, because
the autotools class does that.

As this recipe isn't needed in early build anymore there's no need to
avoid reconfiguring.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/conf/distro/include/maintainers.inc
meta/recipes-devtools/help2man/help2man_1.47.15.bb [moved from meta/recipes-devtools/help2man/help2man-native_1.47.15.bb with 71% similarity]

index 9f80970309f21ebf520d98ac7b3307ace22a5a8f..a094b39b2af2f88ba70b01993fc16f3f58cf522e 100644 (file)
@@ -255,7 +255,7 @@ RECIPE_MAINTAINER_pn-gtk-doc = "Alexander Kanavin <alex.kanavin@gmail.com>"
 RECIPE_MAINTAINER_pn-gzip = "Denys Dmytriyenko <denys@ti.com>"
 RECIPE_MAINTAINER_pn-harfbuzz = "Anuj Mittal <anuj.mittal@intel.com>"
 RECIPE_MAINTAINER_pn-hdparm = "Denys Dmytriyenko <denys@ti.com>"
-RECIPE_MAINTAINER_pn-help2man-native = "Hongxu Jia <hongxu.jia@windriver.com>"
+RECIPE_MAINTAINER_pn-help2man = "Hongxu Jia <hongxu.jia@windriver.com>"
 RECIPE_MAINTAINER_pn-hicolor-icon-theme = "Anuj Mittal <anuj.mittal@intel.com>"
 RECIPE_MAINTAINER_pn-hwlatdetect = "Alexander Kanavin <alex.kanavin@gmail.com>"
 RECIPE_MAINTAINER_pn-i2c-tools = "Anuj Mittal <anuj.mittal@intel.com>"
similarity index 71%
rename from meta/recipes-devtools/help2man/help2man-native_1.47.15.bb
rename to meta/recipes-devtools/help2man/help2man_1.47.15.bb
index 4f80a2bdb10b2d32ac949180b4b4d9dd20f98590..6ab9f6cbe7bbda9e5df4a1ee9a4c0cf961d4b338 100644 (file)
@@ -2,22 +2,21 @@ SUMMARY = "Program for creating simple man pages"
 SECTION = "devel"
 LICENSE = "GPLv3"
 LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
-DEPENDS = "autoconf-native automake-native"
 
 SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz"
 SRC_URI[sha256sum] = "c25a35b30eceb315361484b0ff1f81c924e8ee5c8881576f1ee762f001dbcd1c"
 
-inherit autotools native
+inherit autotools
 
-EXTRA_OECONF = "--disable-nls"
+# This is a hand-maintained aclocal.m4 but our autotools class currently deletes
+# aclocal.m4.
+EXTRA_AUTORECONF += "--exclude=aclocal"
 
-# We don't want to reconfigure things as it would require 'perlnative' to be
-# used.
-do_configure() {
-       oe_runconf
-}
+EXTRA_OECONF = "--disable-nls"
 
 do_install_append () {
        # Make sure we use /usr/bin/env perl
        sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
 }
+
+BBCLASSEXTEND = "native nativesdk"