]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: Add addition environment space to boot loader qemu-system-mips
authorJeff Polk <jeff.polk@windriver.com>
Fri, 28 Mar 2014 09:42:43 +0000 (17:42 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 1 Apr 2014 22:36:20 +0000 (23:36 +0100)
The qemu mips malta base board boot loader uses environment strings
with a max length of 256 bytes which is not long enough to accommodate
a long NFS path in addition to the normal kernel boot command line
arguments.

The solution is to expand the environment string length to 1024 bytes.

Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
Signed-off-by: Roy Li <rongqing.li@windriver.com>
Signed-off-by: Jeff Polk <jeff.polk@windriver.com>
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/qemu/files/qemu-enlarge-env-entry-size.patch [new file with mode: 0644]
meta/recipes-devtools/qemu/qemu_1.7.0.bb

diff --git a/meta/recipes-devtools/qemu/files/qemu-enlarge-env-entry-size.patch b/meta/recipes-devtools/qemu/files/qemu-enlarge-env-entry-size.patch
new file mode 100644 (file)
index 0000000..c7425ab
--- /dev/null
@@ -0,0 +1,31 @@
+qemu: Add addition environment space to boot loader qemu-system-mips 
+
+Upstream-Status: Inappropriate - OE uses deep paths
+
+If you create a project with very long directory names like 128 characters
+deep and use NFS, the kernel arguments will be truncated. The kernel will
+accept longer strings such as 1024 bytes, but the qemu boot loader defaulted
+to only 256 bytes. This patch expands the limit.
+
+Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
+Signed-off-by: Roy Li <rongqing.li@windriver.com>
+---
+ hw/mips/mips_malta.c    |    2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/hw/mips/mips_malta.c b/hw/mips/mips_malta.c
+index 9d521cc..17c0391 100644
+--- a/hw/mips/mips_malta.c
++++ b/hw/mips/mips_malta.c
+@@ -53,7 +53,7 @@
+ #define ENVP_ADDR             0x80002000l
+ #define ENVP_NB_ENTRIES               16
+-#define ENVP_ENTRY_SIZE               256
++#define ENVP_ENTRY_SIZE               1024
+ /* Hardware addresses */
+ #define FLASH_ADDRESS 0x1e000000ULL
+-- 
+1.7.10.4
+
index c0e8b5523e2a607a681cd0ccca116773016b5f4c..be6dd51df4a3934d7a0bc3a406afcc1ba9a1f1d6 100644 (file)
@@ -3,7 +3,8 @@ require qemu.inc
 LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
                     file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
 
-SRC_URI += "file://fxrstorssefix.patch"
+SRC_URI += "file://fxrstorssefix.patch \
+            file://qemu-enlarge-env-entry-size.patch"
 
 SRC_URI_prepend = "http://wiki.qemu.org/download/qemu-${PV}.tar.bz2"
 SRC_URI[md5sum] = "32893941d40d052a5e649efcf06aca06"