]> code.ossystems Code Review - openembedded-core.git/commitdiff
package_regex.inc: split entries which blacklist specific versions to their recipes
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Mon, 16 Nov 2015 14:34:03 +0000 (16:34 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 8 Dec 2015 10:20:09 +0000 (10:20 +0000)
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
14 files changed:
meta/conf/distro/include/package_regex.inc
meta/recipes-devtools/docbook-sgml-dtd/docbook-sgml-dtd-3.1-native_3.1.bb
meta/recipes-devtools/docbook-sgml-dtd/docbook-sgml-dtd-4.1-native_4.1.bb
meta/recipes-devtools/gcc/gcc-4.9.inc
meta/recipes-devtools/python/python.inc
meta/recipes-devtools/python/python3-native_3.5.0.bb
meta/recipes-devtools/python/python3_3.5.0.bb
meta/recipes-extended/unzip/unzip_6.0.bb
meta/recipes-extended/zip/zip_3.0.bb
meta/recipes-multimedia/libtiff/tiff_4.0.4.bb
meta/recipes-qt/qt4/nativesdk-qt4-tools.inc
meta/recipes-qt/qt4/qt4-4.8.7.inc
meta/recipes-qt/qt4/qt4-native.inc
meta/recipes-support/db/db_6.0.30.bb

index 25c59695cbe3104c7f7319814b18a31b2f56a690..c392d6bdcb97621734ea5df8df1e90a852c47900 100644 (file)
@@ -46,25 +46,9 @@ REGEX_pn-cmake = "cmake-(?P<pver>\d+(\.\d+)+)\.tar"
 REGEX_pn-libsdl = "SDL-(?P<pver>\d+(\.\d+)+)\.tar"
 REGEX_pn-libxslt = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
 
-# Exclude NC versions which lack AES encryption
-REGEX_pn-db = "db-(?P<pver>\d+\.\d+(\.\d+)?).tar"
-
 REGEX_URI_pn-autogen = "http://ftp.gnu.org/gnu/autogen/"
 REGEX_pn-autogen = "rel(?P<pver>\d+(\.\d+)+)/"
 
-# python recipe is actually python 2.x
-# also, exclude pre-releases for both python 2.x and 3.x
-REGEX_pn-python = "[Pp]ython-(?P<pver>2(\.\d+)+).tar"
-REGEX_pn-python3 = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
-
-# exclude betas
-REGEX_pn-tiff = "tiff-(?P<pver>\d+(\.\d+)+).tar"
-
-# exclude version 5.5.2 which triggers a false positive
-REGEX_pn-unzip = "unzip(?P<pver>(?!552).+)\.tgz"
-# similar for zip
-REGEX_pn-zip = "^zip(?P<pver>(?!232).+)\.tgz"
-
 # Isn't possible to download with the default URI web server returns
 # (403, 404, 550)
 REGEX_URI_pn-dosfstools = "https://github.com/dosfstools/dosfstools/releases"
@@ -104,22 +88,3 @@ REGEX_URI_pn-libnfsidmap = "http://www.citi.umich.edu/projects/nfsv4/linux/libnf
 REGEX_URI_pn-mpfr = "http://www.mpfr.org/mpfr-current/"
 REGEX_URI_pn-nss = "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_Releases"
 REGEX_pn-nss = "NSS_(?P<pver>.+)_release_notes"
-
-REGEX_URI_pn-docbook-sgml-dtd-3.1 = "http://www.docbook.org/sgml/"
-REGEX_pn-docbook-sgml-dtd-3.1 = "(?P<pver>3\..+)/"
-REGEX_URI_pn-docbook-sgml-dtd-4.1 = "http://www.docbook.org/sgml/"
-REGEX_pn-docbook-sgml-dtd-4.1 = "(?P<pver>4\.1(\.\d+)*)/"
-
-# Qt recipes should be kept at 4.x
-REGEX_URI_pn-qt4-embedded = "http://download.qt.io/official_releases/qt/4.8/"
-REGEX_pn-qt4-embedded = "(?P<pver>\d+(\.\d+)+)/"
-REGEX_URI_pn-qt4-x11-free = "http://download.qt.io/official_releases/qt/4.8/"
-REGEX_pn-qt4-x11-free = "(?P<pver>\d+(\.\d+)+)/"
-REGEX_URI_pn-nativesdk-qt4-tools = "http://download.qt.io/official_releases/qt/4.8/"
-REGEX_pn-nativesdk-qt4-tools = "(?P<pver>\d+(\.\d+)+)/"
-REGEX_URI_pn-qt4-native = "http://download.qt.io/official_releases/qt/4.8/"
-REGEX_pn-qt4-native = "(?P<pver>\d+(\.\d+)+)/"
-
-# Keep old gcc versions at their major versions
-REGEX_pn-gcc-source-4.9.3 = "gcc-(?P<pver>4\.9\.\d+).tar"
-REGEX_pn-gcc-source-4.8.4 = "gcc-(?P<pver>4\.8\.\d+).tar"
index a7df4f976101218d02ca8d4149da74dc5a014c09..a3ee5d83a65b0dc3b6fb3b4e7bd094fad432615f 100644 (file)
@@ -16,6 +16,9 @@ SRC_URI = "http://www.docbook.org/sgml/3.1/docbk31.zip \
 SRC_URI[md5sum] = "432749c0c806dbae81c8bcb70da3b5d3"
 SRC_URI[sha256sum] = "20261d2771b9a052abfa3d8fab1aa62be05791a010281c566f9073bf0e644538"
 
+UPSTREAM_CHECK_URI = "http://www.docbook.org/sgml/"
+UPSTREAM_CHECK_REGEX = "(?P<pver>3\..+)/"
+
 do_compile() {
        # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/sgml-dtd-3.html
        # for details.
index 88c9396360df767bfcd851c5ce579bdd772ffef9..be59680770730e7d876af0d9595ecb915961023b 100644 (file)
@@ -16,6 +16,9 @@ SRC_URI = "http://docbook.org/sgml/4.1/docbk41.zip \
 SRC_URI[md5sum] = "489f6ff2a2173eb1e14216c10533ede2"
 SRC_URI[sha256sum] = "deaafcf0a3677692e7ad4412c0e41c1db3e9da6cdcdb3dd32b2cc1f9c97d6311"
 
+UPSTREAM_CHECK_URI = "http://www.docbook.org/sgml/"
+UPSTREAM_CHECK_REGEX = "(?P<pver>4\.1(\.\d+)*)/"
+
 do_compile() {
        # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/sgml-dtd.html
        # for details.
index 6ac368558b7876f7cd7920b208359226a6e5cae7..bcbc27ebbfe3a7fd62e97eef7b0a4f185ac1a48f 100644 (file)
@@ -86,6 +86,8 @@ SRC_URI = "\
 SRC_URI[md5sum] = "6f831b4d251872736e8e9cc09746f327"
 SRC_URI[sha256sum] = "2332b2a5a321b57508b9031354a8503af6fdfb868b8c1748d33028d100a8b67e"
 
+UPSTREAM_CHECK_REGEX = "gcc-(?P<pver>4\.9\.\d+).tar"
+
 S = "${TMPDIR}/work-shared/gcc-${PV}-${PR}/gcc-${PV}"
 B = "${WORKDIR}/gcc-${PV}/build.${HOST_SYS}.${TARGET_SYS}"
 
index 4d428f3d07e77cae61ccd7a1348ff48b6cb813ab..878f5826bef3b7efd226bf7b3e7c3dd61c6df549 100644 (file)
@@ -12,6 +12,10 @@ SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz"
 SRC_URI[md5sum] = "38d530f7efc373d64a8fb1637e3baaa7"
 SRC_URI[sha256sum] = "90d27e14ea7e03570026850e2e50ba71ad20b7eb31035aada1cf3def8f8d4916"
 
+# python recipe is actually python 2.x
+# also, exclude pre-releases for both python 2.x and 3.x
+UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>2(\.\d+)+).tar"
+
 PYTHON_MAJMIN = "2.7"
 
 inherit autotools
index 198f93d1bf920188687194b5628470fc9d68e677..0dd165019f1a8f51930957e43f19331566aca2df 100644 (file)
@@ -31,6 +31,9 @@ SRC_URI[sha256sum] = "d6d7aa1634a5eeeca6ed4fca266982a04f84bd8f3945a9179e20b24ad2
 
 LIC_FILES_CHKSUM = "file://LICENSE;md5=dd98d01d471fac8d8dbdd975229dba03"
 
+# exclude pre-releases for both python 2.x and 3.x
+UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
+
 S = "${WORKDIR}/Python-${PV}"
 
 EXTRANATIVEPATH += "bzip2-native"
index 2475dba1fcf651121e522aab3903ee89f3303716..7f6fbdb27ca1f37e651887a40f6188b6fec678d6 100644 (file)
@@ -41,6 +41,9 @@ SRC_URI += "\
 SRC_URI[md5sum] = "d149d2812f10cbe04c042232e7964171"
 SRC_URI[sha256sum] = "d6d7aa1634a5eeeca6ed4fca266982a04f84bd8f3945a9179e20b24ad2e2be91"
 
+# exclude pre-releases for both python 2.x and 3.x
+UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
+
 LIC_FILES_CHKSUM = "file://LICENSE;md5=dd98d01d471fac8d8dbdd975229dba03"
 
 S = "${WORKDIR}/Python-${PV}"
index b386323780204a28ed0123cd21b56b417ba75667..77057946233fac2a820ac382af59ae63e37f8704 100644 (file)
@@ -20,6 +20,10 @@ SRC_URI = "ftp://ftp.info-zip.org/pub/infozip/src/unzip60.tgz \
 
 SRC_URI[md5sum] = "62b490407489521db863b523a7f86375"
 SRC_URI[sha256sum] = "036d96991646d0449ed0aa952e4fbe21b476ce994abc276e49d30e686708bd37"
+
+# exclude version 5.5.2 which triggers a false positive
+UPSTREAM_CHECK_REGEX = "unzip(?P<pver>(?!552).+)\.tgz"
+
 S = "${WORKDIR}/unzip60"
 
 # Makefile uses CF_NOOPT instead of CFLAGS.  We lifted the values from
index 1e961101bce1db29e86e989f20182767754bf2fc..383da4b89e3566a7f4e60b604eca0f8aff4e0bbf 100644 (file)
@@ -8,6 +8,9 @@ S = "${WORKDIR}/zip30"
 SRC_URI[md5sum] = "7b74551e63f8ee6aab6fbc86676c0d37"
 SRC_URI[sha256sum] = "f0e8bb1f9b7eb0b01285495a2699df3a4b766784c1765a8f1aeedf63c0806369"
 
+# exclude version 2.3.2 which triggers a false positive
+UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz"
+
 # zip.inc sets CFLAGS, but what Makefile actually uses is
 # CFLAGS_NOOPT.  It will also force -O3 optimization, overriding
 # whatever we set.
index cf3a5f04c5c456105c08ea0fef76ebe6c87b2afc..74f0a7228c4a4baecb12ee23b0720f7ae422cc4f 100644 (file)
@@ -10,6 +10,9 @@ SRC_URI = "ftp://ftp.remotesensing.org/pub/libtiff/tiff-${PV}.tar.gz \
 SRC_URI[md5sum] = "9aee7107408a128c0c7b24286c0db900"
 SRC_URI[sha256sum] = "8cb1d90c96f61cdfc0bcf036acc251c9dbe6320334da941c7a83cfe1576ef890"
 
+# exclude betas
+UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
+
 inherit autotools
 
 CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
index 077008bb8bdc91a8f59c213520912137303d9163..54bf2a12a56e0634e1c45b713aa7f5e9fe7b0026 100644 (file)
@@ -18,6 +18,9 @@ SRC_URI = "http://download.qt-project.org/official_releases/qt/4.8/${PV}/qt-ever
            file://g++.conf \
            file://linux.conf"
 
+UPSTREAM_CHECK_URI = "http://download.qt.io/official_releases/qt/4.8/"
+UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)/"
+
 S = "${WORKDIR}/qt-everywhere-opensource-src-${PV}"
 
 LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=fbc093901857fcd118f065f900982c24 \
index d71c68d411a2a996456436edc186329386756c94..3cf7c380ab5c78fa8082e2d0bfa4e18a4f0b7713 100644 (file)
@@ -35,6 +35,9 @@ SRC_URI = "http://download.qt-project.org/official_releases/qt/4.8/${PV}/qt-ever
 SRC_URI[md5sum] = "d990ee66bf7ab0c785589776f35ba6ad"
 SRC_URI[sha256sum] = "e2882295097e47fe089f8ac741a95fef47e0a73a3f3cdf21b56990638f626ea0"
 
+UPSTREAM_CHECK_URI = "http://download.qt.io/official_releases/qt/4.8/"
+UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)/"
+
 S = "${WORKDIR}/qt-everywhere-opensource-src-${PV}"
 
 # disable webkit for mips64 n32 temporarily that fails to compile,
index 2a41f8ab298a3564a0cd520f464c6ec8ab11bdc6..58acac87ed0bb240c6410e384a4d49b8812cedde 100644 (file)
@@ -19,6 +19,10 @@ SRC_URI = "http://download.qt-project.org/official_releases/qt/4.8/${PV}/qt-ever
            file://g++.conf \
            file://linux.conf \
        "
+
+UPSTREAM_CHECK_URI = "http://download.qt.io/official_releases/qt/4.8/"
+UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)/"
+
 S = "${WORKDIR}/qt-everywhere-opensource-src-${PV}"
 
 EXTRA_OECONF = "-prefix ${prefix} \
index ccdb6bd30241674c35dec02dfdab3fb2b1f825f8..db9f0ab7c991096cf055f2983316a818824c12e9 100644 (file)
@@ -27,6 +27,10 @@ SRC_URI += "file://arm-thumb-mutex_db5.patch;patchdir=.. \
 SRC_URI[md5sum] = "ad28eb86ad3203b5422844db179c585b"
 SRC_URI[sha256sum] = "608e4b1cf390e9bf54c0ef00c5bd9ca76d36e2261b9f4d33d54516f3f6a20fd2"
 
+# Exclude NC versions which lack AES encryption
+UPSTREAM_CHECK_REGEX = "db-(?P<pver>\d+\.\d+(\.\d+)?).tar"
+UPSTREAM_CHECK_URI = "http://www.oracle.com/technetwork/products/berkeleydb/downloads/index-082944.html"
+
 LIC_FILES_CHKSUM = "file://../LICENSE;md5=1ec8b0b17cc31513fe35ab10716f8490"
 
 inherit autotools