]> code.ossystems Code Review - openembedded-core.git/commitdiff
valgrind: fix the shared object issue while prelink ptest
authorZhixiong Chi <zhixiong.chi@windriver.com>
Wed, 11 Apr 2018 08:26:18 +0000 (16:26 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 13 Apr 2018 15:55:26 +0000 (16:55 +0100)
If valgrind-ptest is installed, we will get the some prelink error
like below at do_image:

  .../usr/sbin/prelink: /usr/lib64/valgrind/ptest/memcheck/tests/wrap7:\
  Could not find one of the dependencies: \
  .../usr/sbin//prelink-rtld: error   \
  while loading shared libraries: wrap7so.so: cannot open shared  \
  object file: No such file or directory

The wrap7 needs to link the shared object in the path
/usr/lib64/valgrind/ptest/memcheck/tests, but it fails.
So we correct the path for ptest.

Signed-off-by: Zhixiong Chi <zhixiong.chi@windriver.com>
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/valgrind/valgrind/0002-remove-rpath.patch [deleted file]
meta/recipes-devtools/valgrind/valgrind_3.13.0.bb

diff --git a/meta/recipes-devtools/valgrind/valgrind/0002-remove-rpath.patch b/meta/recipes-devtools/valgrind/valgrind/0002-remove-rpath.patch
deleted file mode 100644 (file)
index e9112da..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-From f96cf1f4eaa72860ab8b5e18ad10fdc704d78c5f Mon Sep 17 00:00:00 2001
-From: Alexander Kanavin <alex.kanavin@gmail.com>
-Date: Tue, 15 Dec 2015 15:01:34 +0200
-Subject: [PATCH 2/5] remove rpath
-
-Upstream-Status: Inappropriate [embedded config]
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
----
- none/tests/Makefile.am | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/none/tests/Makefile.am b/none/tests/Makefile.am
-index 54f2a7e..25b0f49 100644
---- a/none/tests/Makefile.am
-+++ b/none/tests/Makefile.am
-@@ -326,7 +326,6 @@ threadederrno_CFLAGS       += --std=c99
- endif
- tls_SOURCES           = tls.c tls2.c
- tls_DEPENDENCIES      = tls.so tls2.so
--tls_LDFLAGS           = -Wl,-rpath,$(abs_top_builddir)/none/tests
- tls_LDADD             = tls.so tls2.so -lpthread
- tls_so_SOURCES                = tls_so.c
- tls_so_DEPENDENCIES   = tls2.so
-@@ -334,7 +333,7 @@ if VGCONF_OS_IS_DARWIN
-  tls_so_LDFLAGS               = -dynamic -dynamiclib -all_load -fpic
-  tls_so_LDADD         = `pwd`/tls2.so
- else
-- tls_so_LDFLAGS               = -Wl,-rpath,$(abs_top_builddir)/none/tests -shared -fPIC
-+ tls_so_LDFLAGS               = -shared -fPIC
-  tls_so_LDADD         = tls2.so
- endif
- tls_so_CFLAGS         = $(AM_CFLAGS) -fPIC
--- 
-2.6.2
-
index 9390d304441a103c762d4c15d825a07afc578f16..d3af35e7f8bb1b13ca7252dfcebcfc2fa5eb6eac 100644 (file)
@@ -16,7 +16,6 @@ SRC_URI = "ftp://sourceware.org/pub/valgrind/valgrind-${PV}.tar.bz2 \
            file://fixed-perl-path.patch \
            file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
            file://run-ptest \
-           file://0002-remove-rpath.patch \
            file://0004-Fix-out-of-tree-builds.patch \
            file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \
            file://0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch \
@@ -87,6 +86,8 @@ def get_mcpu(d):
 
 do_configure_prepend () {
     rm -rf ${S}/config.h
+    sed -i -e 's:$(abs_top_builddir):$(pkglibdir)/ptest:g' ${S}/none/tests/Makefile.am
+    sed -i -e 's:$(top_builddir):$(pkglibdir)/ptest:g' ${S}/memcheck/tests/Makefile.am
 }
 
 do_install_append () {