]> code.ossystems Code Review - openembedded-core.git/commitdiff
alsa-lib: fix softfloat enabling
authorTanu Kaskinen <tanuk@iki.fi>
Wed, 15 Feb 2017 07:13:02 +0000 (09:13 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 23 Feb 2017 20:29:19 +0000 (12:29 -0800)
EXTRA_OECONF = "--disable-python" overrode the previous EXTRA_OECONF
assignment, so softfloat didn't get enabled when needed. Fixed this by
replacing "=" with "+=".

Bitbake then complained about tabs in alsa-fpu.inc, changed them to
spaces.

Signed-off-by: Tanu Kaskinen <tanuk@iki.fi>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-multimedia/alsa/alsa-fpu.inc
meta/recipes-multimedia/alsa/alsa-lib_1.1.3.bb

index 1ca31e749815667a597d4af83c69db5ee02b10b5..355a9dfcd1088e30f2eca8ea08eff5d419becaa7 100644 (file)
@@ -1,6 +1,4 @@
-
 def get_alsa_fpu_setting(bb, d):
-       if d.getVar('TARGET_FPU') in [ 'soft' ]:
-               return "--with-softfloat"
-       return ""
-
+    if d.getVar('TARGET_FPU') in [ 'soft' ]:
+        return "--with-softfloat"
+    return ""
index 5c213bebde19d65dd3dfe0883949bb26f363d9b5..34a7d8802efb46b269093b2789f814c52b791d1a 100644 (file)
@@ -21,7 +21,7 @@ inherit autotools pkgconfig
 require alsa-fpu.inc
 EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
 
-EXTRA_OECONF = "--disable-python"
+EXTRA_OECONF += "--disable-python"
 
 EXTRA_OECONF_append_libc-uclibc = " --with-versioned=no "