]> code.ossystems Code Review - openembedded-core.git/commitdiff
nasm: Fix case where ${B} != ${S} (partial)
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2013 02:05:06 +0000 (02:05 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2013 13:17:39 +0000 (13:17 +0000)
Fix out of tree build by fixing cwd assumptions.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/nasm/nasm_2.10.07.bb

index 1c95ed82bc40332273be25f781b0a6be26d3215e..bcecce4a8172ba23b7427f773691de0b98067a42 100644 (file)
@@ -13,8 +13,8 @@ SRC_URI[sha256sum] = "c056e2abc83816892e448f9e9e95a3d21e9e096f44341b9d4853f62a44
 inherit autotools
 
 do_configure_prepend () {
-       if [ -f aclocal.m4 ] && [ ! -f acinclude.m4 ]; then
-               mv aclocal.m4 acinclude.m4
+       if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
+               mv ${S}/aclocal.m4 ${S}/acinclude.m4
        fi
 }