]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssh: build regression test binaries
authorJussi Kukkonen <jussi.kukkonen@intel.com>
Wed, 19 Aug 2015 08:51:04 +0000 (11:51 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 24 Aug 2015 22:43:24 +0000 (23:43 +0100)
ptests were failing and many more were being silently skipped because
required binaries were not being built.

Build the binaries in regress/ and set SUDO environment variable in
run-ptests: after this all tests in regress/ are now run. Continue to
skip building binaries in regress/unittests/: unittest runtime is
excessive.

On a NUC running intel-corei7-64 core-image-sato, new results are:
PASS: 55, SKIP: 3, FAIL: 0

[YOCTO #8153]

Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-connectivity/openssh/openssh/run-ptest
meta/recipes-connectivity/openssh/openssh_7.0p1.bb

index 3e725cf282adcddda002f24b3fc28c6bc737a1d2..564c0c82565ba09bdf146d8bbf310793c75e8b5f 100755 (executable)
@@ -3,5 +3,5 @@
 export TEST_SHELL=sh
 
 cd regress
-make -k .OBJDIR=`pwd` .CURDIR=`pwd` tests \
+make -k .OBJDIR=`pwd` .CURDIR=`pwd` SUDO="sudo" tests \
         | sed -e 's/^skipped/SKIP: /g' -e 's/^ok /PASS: /g' -e 's/^failed/FAIL: /g'
index 105875a60d2d0b7bbb2c58801cd36546429bbbbc..67abe577b56c61a1a4a7146cf05537b9b0cae46a 100644 (file)
@@ -79,6 +79,12 @@ do_configure_prepend () {
        fi
 }
 
+do_compile_ptest() {
+        # skip regress/unittests/ binaries: this will silently skip
+        # unittests in run-ptests which is good because they are so slow.
+        oe_runmake regress/modpipe regress/setuid-allowed regress/netcat
+}
+
 do_install_append () {
        if [ "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" = "pam" ]; then
                install -D -m 0755 ${WORKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd