]> code.ossystems Code Review - openembedded-core.git/commitdiff
shaderc: avoid reproducible issues
authorJose Quaresma <quaresma.jose@gmail.com>
Sun, 24 Jan 2021 18:07:57 +0000 (18:07 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 29 Jan 2021 15:59:33 +0000 (15:59 +0000)
Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/shaderc/shaderc_2020.4.bb

index ee9b1183711fcfbcdb4dcd9620986662962e06cb..e886e81d0e4268bf9ea8da69293cfe68a30aa78b 100644 (file)
@@ -19,15 +19,17 @@ DEPENDS = "spirv-tools glslang"
 
 EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DSHADERC_SKIP_TESTS=ON"
 
+BBCLASSEXTEND = "native nativesdk"
+
+# TODO: probably there is better solution for this.
+# I don't know any method for get the version of a receipe in DEPENDS,
+# so do this ugly hack
+inherit pkgconfig
+DEPENDS += "glslang-native"
 do_configure_prepend() {
-    # TODO: probably there is better solution for this.
-    # I dont know any method for get the version of a receipe in DEPENDS
-    # so do this ugly hack
     cat <<- EOF > ${S}/glslc/src/build-version.inc
 "${PV}\\n"
 "$(pkg-config --modversion SPIRV-Tools)\\n"
 "$(glslangValidator --version | head -1 | cut -d' ' -f3)\\n"
 EOF
 }
-
-BBCLASSEXTEND = "native nativesdk"