]> code.ossystems Code Review - openembedded-core.git/commitdiff
coreutils 6.9: fix unknown-configure-option
authorRobert Yang <liezhi.yang@windriver.com>
Fri, 13 Feb 2015 03:02:55 +0000 (19:02 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 14 Feb 2015 22:26:11 +0000 (22:26 +0000)
Fixed:
WARNING: QA Issue: coreutils: configure was passed unrecognised options: --disable-acl [unknown-configure-option]

It doesn't support --enable-acl or --disable-acl, use
ac_cv_header_acl_libacl_h to fix the problem.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/coreutils/coreutils_6.9.bb

index 7f34e1b73cab0c4fc2b26820646925ebe60329ce..9189426315e015ef118961cf3309d1c079fc67a1 100644 (file)
@@ -37,7 +37,7 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}
 
 # with, without, depends, rdepends
 #
-PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
+PACKAGECONFIG[acl] = "ac_cv_header_sys_acl_h=yes,ac_cv_header_sys_acl_h=no,acl,"
 
 
 # [ gets a special treatment and is not included in this