]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg: enable libsolv backend by default
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>
Wed, 8 Mar 2017 21:40:14 +0000 (15:40 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 11 Mar 2017 16:08:48 +0000 (16:08 +0000)
The libsolv backend is vastly superior than the currently enabled
internal ad-hoc solver. While the switch does have a small impact on
disk and memory footprint, it make sense to change the default as for
most cases the disk/memory footprint hit should be acceptable.

========================
Disk Footprint Increase
========================
qemux86-64  523K
qemuarm    445K
qemux86    576K

====================================================
Command [1]           Libsolv      Internal Solver
====================================================
opkg update          26.21 MB      26.21 MB
opkg list            29.87 MB      29.87 MB
opkg install procps  30.99 MB      27.33 MB
opkg remove procps    1.69 MB       1.69 MB
opkg update      30.97 MB    27.75 MB

[1] Profile done via 'valgrind --tool=massif <command>' in a feed with
~18K packages.

Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/opkg/opkg_0.3.4.bb

index 6ac94382683fc4d0bb3e5e8e36a7eea7b2848f7e..e298185723833fa2493cee228b8759c6fe173ba2 100644 (file)
@@ -28,7 +28,7 @@ SYSTEMD_SERVICE_${PN} = "opkg-configure.service"
 target_localstatedir := "${localstatedir}"
 OPKGLIBDIR = "${target_localstatedir}/lib"
 
-PACKAGECONFIG ??= ""
+PACKAGECONFIG ??= "libsolv"
 
 PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg"
 PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"