]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-pygpgme: add a recipe
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Fri, 10 Mar 2017 11:23:47 +0000 (13:23 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 11 Mar 2017 16:08:50 +0000 (16:08 +0000)
python-pygpgme is required by dnf.

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python-pygpgme_0.3.bb [new file with mode: 0644]

diff --git a/meta/recipes-devtools/python/python-pygpgme_0.3.bb b/meta/recipes-devtools/python/python-pygpgme_0.3.bb
new file mode 100644 (file)
index 0000000..f7dd835
--- /dev/null
@@ -0,0 +1,18 @@
+SUMMARY = "A Python module for working with OpenPGP messages"
+HOMEPAGE = "https://launchpad.net/pygpgme"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://README;md5=2dc15a76acf01e126188c8de634ae4b3"
+
+SRC_URI = "https://launchpad.net/pygpgme/trunk/${PV}/+download/pygpgme-${PV}.tar.gz"
+SRC_URI[md5sum] = "d38355af73f0352cde3d410b25f34fd0"
+SRC_URI[sha256sum] = "5fd887c407015296a8fd3f4b867fe0fcca3179de97ccde90449853a3dfb802e1"
+
+S = "${WORKDIR}/pygpgme-${PV}"
+
+inherit distutils
+
+DEPENDS = "gpgme python"
+
+RDEPENDS_${PN} += "python-core"
+
+BBCLASSEXTEND = "native"