]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-flit-core: inherit pip_install_wheel
authorTim Orling <ticotimo@gmail.com>
Thu, 24 Feb 2022 23:45:14 +0000 (15:45 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 25 Feb 2022 15:06:46 +0000 (15:06 +0000)
Keep the pip install logic, especially --root in one place to ensure
that we fix e.g. reproducible issues in one place.

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3-flit-core_3.6.0.bb

index 6dfacafd31c238e81727e6838e205f37aba3dafb..a00ea1810e326ed38a3a5e1005c4a98b39525c9c 100644 (file)
@@ -10,24 +10,21 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=41eb78fa8a872983a882c694a8305f08"
 
 SRC_URI[sha256sum] = "b1464e006df4df4c8eeb37671c0e0ce66e1d04e4a36d91b702f180a25fde3c11"
 
-inherit python3native python3-dir pypi setuptools3-base
+inherit pip_install_wheel python3native python3-dir pypi setuptools3-base
 
-DEPENDS:append:class-target = " python3-pip-native"
+DEPENDS:remove:class-native = " python3-pip-native"
 DEPENDS:append:class-native = " unzip-native"
 
 # We need the full flit tarball
 PYPI_PACKAGE = "flit"
 
+PIP_INSTALL_PACKAGE = "flit_core"
+PIP_INSTALL_DIST_PATH = "${S}/flit_core/dist"
+
 do_compile () {
     nativepython3 flit_core/build_dists.py
 }
 
-do_install () {
-    install -d ${D}${PYTHON_SITEPACKAGES_DIR}
-    PYTHONPATH=${D}${PYTHON_SITEPACKAGES_DIR} \
-    nativepython3 -m pip install -vvvv --no-deps --no-index --target ${D}${PYTHON_SITEPACKAGES_DIR} ./flit_core/dist/flit_core-${PV}-py3-none-any.whl
-}
-
 do_install:class-native () {
     install -d ${D}${PYTHON_SITEPACKAGES_DIR}
     unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ./flit_core/dist/flit_core-${PV}-py3-none-any.whl