]> code.ossystems Code Review - openembedded-core.git/commitdiff
automake: Extend to provide nativesdk recipe
authorWenzong Fan <wenzong.fan@windriver.com>
Wed, 30 Nov 2011 08:45:43 +0000 (16:45 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 30 Nov 2011 15:09:34 +0000 (15:09 +0000)
We will provide autotools nativesdk in meta-tookchain for reconfigure
any autotools supported projects, as a part of the plan we should extend
their recipes first.

Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/automake/automake.inc
meta/recipes-devtools/automake/automake_1.11.1.bb

index 370a9725663088e2534a288da30dcfb3112cc33f..25b0c0ecd6a290299b11e62121dbcf224a24b103 100644 (file)
@@ -4,7 +4,7 @@ Standards. Automake requires the use of Autoconf."
 LICENSE = "GPLv2"
 HOMEPAGE = "http://www.gnu.org/software/automake/"
 SECTION = "devel"
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 "
 
index 18450a0140617b31ac234b4d72acf41cf517954c..ff8353fe82c6e39fa98791368176e0fc5b5a8471 100644 (file)
@@ -31,6 +31,7 @@ RDEPENDS_automake-native = "autoconf-native perl-native-runtime"
 
 PATHFIXPATCH = "file://path_prog_fixes.patch"
 PATHFIXPATCH_virtclass-native = ""
+PATHFIXPATCH_virtclass-nativesdk = ""
 
 SRC_URI += "${PATHFIXPATCH} \
            file://prefer-cpio-over-pax-for-ustar-archives.patch \
@@ -44,4 +45,4 @@ do_install () {
        install -d ${D}${datadir}
 }
 
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"