]> code.ossystems Code Review - openembedded-core.git/commitdiff
apt: Add db/db-native as a DEPENDS so apt-ftparchive gets built (needed by deb rootfs...
authorRichard Purdie <richard@openedhand.com>
Tue, 21 Aug 2007 14:00:13 +0000 (14:00 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 21 Aug 2007 14:00:13 +0000 (14:00 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2531 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/apt/apt-native.inc
meta/packages/apt/apt-native_0.7.2.bb
meta/packages/apt/apt-native_0.7.3.bb
meta/packages/apt/apt.inc
meta/packages/apt/files/db_linking_hack.patch [new file with mode: 0644]

index 942f4991d34071e1a2e20fa70b99fa8ff2adf7f1..75cd8f47cd1b88908b11ab66726c058a81f8ecdf 100644 (file)
@@ -1,11 +1,13 @@
 require apt.inc
 inherit native
 
-DEPENDS += "dpkg-native curl-native"
+DEPENDS += "dpkg-native curl-native db-native"
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/apt-${PV}"
 PACKAGES = ""
 USE_NLS = "no"
 
+SRC_URI += "file://db_linking_hack.patch;patch=1"
+
 python do_stage () {
        bb.build.exec_func('do_stage_base', d)
        bb.build.exec_func('do_stage_config', d)
@@ -35,7 +37,7 @@ do_stage_base () {
        install -m 0755 bin/apt-get ${bindir}/
        install -m 0755 bin/apt-config ${bindir}/
        install -m 0755 bin/apt-cache ${bindir}/
-
+       install -m 0755 bin/apt-ftparchive ${bindir}/
        install -m 0755 bin/apt-sortpkgs ${bindir}/
        install -m 0755 bin/apt-extracttemplates ${bindir}/
 
index 43f73889f7d47f13dc0d5935eff14b21a83d8a48..3342618aa9a98c2fa0e17a739fef83fcc6a763b9 100644 (file)
@@ -1,4 +1,5 @@
 require apt-native.inc
+PR = "r1"
 
 SRC_URI += "file://nodoc.patch;patch=1 \
             file://noconfigure.patch;patch=1"
index 3342618aa9a98c2fa0e17a739fef83fcc6a763b9..6db567f9871e36179dedb10bfc679af169834c4f 100644 (file)
@@ -1,5 +1,5 @@
 require apt-native.inc
-PR = "r1"
+PR = "r2"
 
 SRC_URI += "file://nodoc.patch;patch=1 \
             file://noconfigure.patch;patch=1"
index 6c9632e8ff5ff00aa7d66b968d09b31d8b7b6607..92507be188a08f517a9a85cbfeb7a9cdd7a2c753 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Advanced front-end for dpkg."
 LICENSE = "GPL"
 SECTION = "base"
-DEPENDS = "curl"
+DEPENDS = "curl db"
 RDEPENDS = "dpkg"
 
 SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \
diff --git a/meta/packages/apt/files/db_linking_hack.patch b/meta/packages/apt/files/db_linking_hack.patch
new file mode 100644 (file)
index 0000000..3c8368b
--- /dev/null
@@ -0,0 +1,27 @@
+Index: apt-0.7.3/configure.in
+===================================================================
+--- apt-0.7.3.orig/configure.in        2007-07-01 10:38:45.000000000 +0000
++++ apt-0.7.3/configure.in     2007-08-21 13:39:26.000000000 +0000
+@@ -67,8 +67,20 @@
+       [AC_DEFINE(HAVE_BDB)
+        BDBLIB="-ldb"
+        AC_MSG_RESULT(yes)],
+-      [BDBLIB=""
+-       AC_MSG_RESULT(no)]
++
++       LIBS="$LIBS -lpthread"
++       [AC_MSG_CHECKING(if we can link against BerkeleyDB with pthread)
++        AC_LINK_IFELSE(
++        [AC_LANG_PROGRAM(
++         [#include <db.h>],
++         [int r, s, t; db_version(&r, &s, &t);]
++        )],
++        [AC_DEFINE(HAVE_BDB)
++         BDBLIB="-ldb -lpthread"
++         AC_MSG_RESULT(yes)],
++        [BDBLIB=""
++         AC_MSG_RESULT(no)]
++      )]       
+     )]
+ )