]> code.ossystems Code Review - openembedded-core.git/commitdiff
file-native: Add 4.18 from OE.dev
authorRichard Purdie <richard@openedhand.com>
Mon, 20 Nov 2006 15:26:57 +0000 (15:26 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 20 Nov 2006 15:26:57 +0000 (15:26 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@886 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/file/file-native_4.18.bb [new file with mode: 0644]
meta/packages/file/file_4.18.bb [new file with mode: 0644]

diff --git a/meta/packages/file/file-native_4.18.bb b/meta/packages/file/file-native_4.18.bb
new file mode 100644 (file)
index 0000000..63554b0
--- /dev/null
@@ -0,0 +1,8 @@
+require file_${PV}.bb
+inherit native
+
+# avoid dependency loop
+DEPENDS = ""
+PR = "r1"
+
+SRC_URI += "file://native-fix.diff;patch=1"
diff --git a/meta/packages/file/file_4.18.bb b/meta/packages/file/file_4.18.bb
new file mode 100644 (file)
index 0000000..697d4ff
--- /dev/null
@@ -0,0 +1,22 @@
+DESCRIPTION = "File attempts to classify files depending \
+on their contents and prints a description if a match is found."
+SECTION = "console/utils"
+LICENSE = "BSD-ADV"
+DEPENDS = "file-native"
+
+SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
+           file://dump \
+           file://filesystems"
+S = "${WORKDIR}/file-${PV}"
+
+inherit autotools 
+
+do_configure_prepend() {
+       sed -i -e 's,$(top_builddir)/src/file,file,' ${S}/magic/Makefile.am
+       cp ${WORKDIR}/dump ${S}/magic/Magdir/
+       cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
+}
+
+do_stage() {
+       autotools_stage_all
+}