]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta-environment: Remove the recursive dependency on do_compile
authorDongxiao Xu <dongxiao.xu@intel.com>
Thu, 20 Jan 2011 04:54:48 +0000 (12:54 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 20 Jan 2011 23:29:43 +0000 (23:29 +0000)
It is not needed to have dependency on each do_compile of its recursive
depend tasks.

This problem is triggered by building meta-toolchain-sdk from prebuilt
result. Some packages like quilt-native, which is already been populated
and packaged by do_populate_sysroot_setscene and
do_package_write_xxx_setscene, however this recursive dependency of
do_compile triggers the tasks flow of "do_setscene --> do_fetch -->
do_unpack --> ..." again and do_setscene removes all the quilt-native
files, making the other recipes failed while do_patch.

Thanks for Kevin's help in root causing this issue.

CC: Lianhao Lu <lianhao.lu@intel.com>
Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
meta/recipes-core/meta/meta-environment.bb

index 9f7e382d72e4e60755b6d7b716e4c23fa269be38..4ba919f7febbaa4aca07321f9cc0a30ef5987074 100644 (file)
@@ -39,7 +39,6 @@ do_generate_content() {
     echo 'Metadata Revision: ${METADATA_REVISION}' >> $versionfile
     echo 'Timestamp: ${DATETIME}' >> $versionfile
 }
-do_generate_content[recrdeptask] = "do_compile"
 addtask generate_content before do_install after do_compile
 
 do_install[nostamp] = "1"