]> code.ossystems Code Review - openembedded-core.git/commitdiff
gmp: Don't check "$CC $CFLAGS" for x32 in gmp configure
authorH.J. Lu <hjl.tools@gmail.com>
Fri, 9 Dec 2011 18:45:02 +0000 (10:45 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 Dec 2011 13:13:30 +0000 (13:13 +0000)
There is no need to check "$CC $CFLAGS" for x32 in gmp configure.  The
way GMP works is that it makes all the ABIs available for the user to
pick from based on the target, but the final ABI is selected based on
the $ABI variable or if compiler passes the ABI test.  The test for
x32 ABI is

any_x32_testlist="sizeof-long-4"

GMP will select x32 ABI only if long is 4byte, which will only be set
to 4 by -mx32 passed in "$CC $CFLAGS".

Signed-off-by: H.J. Lu <hjl.tools@gmail.com>
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/recipes-support/gmp/gmp/gmp_fix_for_x32.patch

index b8e22aa00240bb6f24044b255b06b4faa32d4b2d..76d3a004d32ad7c86781484bcf78e3c06ba21581 100644 (file)
@@ -8,7 +8,7 @@ Signed Off By: Nitin A Kamble <nitin.a.kamble@intel.com> 2011/11/21
 
 --- gmp-4.3.2/configure.in.x32 2011-08-12 15:03:06.143548291 -0700
 +++ gmp-4.3.2/configure.in     2011-08-12 15:06:20.580595316 -0700
-@@ -1499,6 +1499,25 @@ case $host in
+@@ -1499,6 +1499,21 @@ case $host in
            path_64="x86_64/atom x86_64"
            ;;
        esac
@@ -16,19 +16,15 @@ Signed Off By: Nitin A Kamble <nitin.a.kamble@intel.com> 2011/11/21
 +      # X32 support.
 +      case x"$path_64" in
 +        xx86_64*)
-+          case x"$CC $CFLAGS" in
-+            x*-mx32*)
-+              abilist="x32 64 32"
-+              path_x32="$path_64"
-+              limb_x32=longlong
-+              cclist_x32="gcc"
-+              gcc_x32_cflags="-O2 -mx32"
-+              any_x32_testlist="sizeof-long-4"
-+              CALLING_CONVENTIONS_OBJS_x32='amd64call.lo amd64check$U.lo'
-+              SPEED_CYCLECOUNTER_OBJ_x32=x86_64.lo
-+              cyclecounter_size_x32=2
-+              ;;
-+          esac
++          abilist="x32 64 32"
++          path_x32="$path_64"
++          limb_x32=longlong
++          cclist_x32="gcc"
++          gcc_x32_cflags="-O2 -mx32"
++          any_x32_testlist="sizeof-long-4"
++          CALLING_CONVENTIONS_OBJS_x32='amd64call.lo amd64check$U.lo'
++          SPEED_CYCLECOUNTER_OBJ_x32=x86_64.lo
++          cyclecounter_size_x32=2
 +          ;;
 +      esac
        ;;