]> code.ossystems Code Review - openembedded-core.git/commitdiff
networkmanager/matchbox-keyboard: Use exec to run the final programs
authorRichard Purdie <richard@openedhand.com>
Tue, 19 Aug 2008 21:53:15 +0000 (21:53 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 19 Aug 2008 21:53:15 +0000 (21:53 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5084 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/matchbox-keyboard/files/80matchboxkeyboard.shbg
meta/packages/matchbox-keyboard/matchbox-keyboard_svn.bb
meta/packages/networkmanager/files/70NetworkManagerApplet.shbg
meta/packages/networkmanager/networkmanager-applet_svn.bb

index e6745c5695244b9a4666acfb033e6d369193faf7..43c5d3ed6a32b6b9dbd197f1538cdad433686135 100755 (executable)
@@ -19,5 +19,5 @@ if [ "$CMD" ]; then
     # Delay to make sure the window manager is active
     # by waiting for the desktop to say its finished loading
     dbus-wait org.matchbox_project.desktop Loaded
-    $CMD
+    exec $CMD
 fi
index 7afe8eb60f5afebd2d23b8b077b72e0093a10c0e..568a83e516ba95ef625afc3f6a1a8ae083979129 100644 (file)
@@ -4,7 +4,7 @@ DEPENDS = "libfakekey expat libxft gtk+ matchbox-panel-2"
 RDEPENDS = "formfactor dbus-wait"
 SECTION = "x11"
 PV = "0.0+svnr${SRCREV}"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
            file://configure_fix.patch;patch=1;maxrev=1819 \
index 55248ede9b57904fafc506838624ad8b61f2bb32..8858b3e7c240d255995d9f22bcf141351308faf9 100644 (file)
@@ -1,4 +1,4 @@
 #!/bin/sh
 # Wait for the desktop to say its finished loading
 dbus-wait org.matchbox_project.desktop Loaded
-/usr/bin/nm-applet
+exec /usr/bin/nm-applet
index 6473fc9e6dd1466c3c5dea356c29108ddd483bea..27108d2823e03f852c482ddf2e39ad49c145da18 100644 (file)
@@ -3,7 +3,7 @@ LICENSE = "GPL"
 DEPENDS = "networkmanager dbus-glib libglade gconf gnome-keyring"
 #TODO DEPENDS libnotify
 RDEPENDS = "networkmanager dbus-wait"
-PR = "r6"
+PR = "r7"
 
 inherit gnome gtk-icon-cache