]> code.ossystems Code Review - openembedded-core.git/commitdiff
sysvinit-inittab_2.88dsf.bb: only run serial checks at boot if we have items to check
authorMatthew McClintock <msm@freescale.com>
Tue, 11 Sep 2012 17:56:53 +0000 (12:56 -0500)
committerScott Garman <scott.a.garman@intel.com>
Mon, 24 Sep 2012 16:51:12 +0000 (09:51 -0700)
Right now, we delay running the serial console checks to we boot up. This causes
issues for read only file systems. So, if have not configured any serial ports to
check via SERIAL_CONSOLES_CHECK we can skip the check at boot. This fixes any
issues with read only file systems and ipk packaging.

Signed-off-by: Matthew McClintock <msm@freescale.com>
meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb

index 1089edbcb445d0824db48b323b547337dc22f2fc..5b79caffc2b5fff1d0acd783e1f4fe27dc2999b3 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Inittab for sysvinit"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-PR = "r7"
+PR = "r8"
 
 SRC_URI = "file://inittab"
 
@@ -54,7 +54,7 @@ EOF
 
 pkg_postinst_${PN} () {
 # run this on the target
-if [ "x$D" == "x" ]; then
+if [ "x$D" = "x" ]; then
        tmp="${SERIAL_CONSOLES_CHECK}"
        for i in $tmp
        do
@@ -65,7 +65,11 @@ if [ "x$D" == "x" ]; then
        done
        kill -HUP 1
 else
-       exit 1
+       if [ "${SERIAL_CONSOLES_CHECK}" = "" ]; then
+               exit 0
+       else
+               exit 1
+       fi
 fi
 }