]> code.ossystems Code Review - openembedded-core.git/commitdiff
exmap-console: Use filename to set PV, remove duplication from svn version, set DEPEN...
authorRichard Purdie <richard@openedhand.com>
Thu, 22 Feb 2007 08:38:46 +0000 (08:38 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 22 Feb 2007 08:38:46 +0000 (08:38 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1285 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/exmap-console/exmap-console.bb [deleted file]
meta/packages/exmap-console/exmap-console.inc
meta/packages/exmap-console/exmap-console_0.4.bb [new file with mode: 0644]
meta/packages/exmap-console/exmap-console_svn.bb

diff --git a/meta/packages/exmap-console/exmap-console.bb b/meta/packages/exmap-console/exmap-console.bb
deleted file mode 100644 (file)
index a872dee..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-
-PV="0.4"
-
-require exmap-console.inc
\ No newline at end of file
index 3ebe21c8badbe6fb4270ab282984e3810009a2e3..bdd1fdd44c4d04fe708ff1d99039de94baa8a67f 100644 (file)
@@ -1,10 +1,10 @@
-DESCRIPTION = "console-based exmap"
-HOMEPAGE = "http://www.o-hand.com"
+DESCRIPTION = "Console based version of exmap, a memory usage analysis tool"
+HOMEPAGE = "http://projects.o-hand.com/exmap-console"
 SECTION = "devel"
 LICENSE = "GPL"
+DEPENDS = "virtual/kernel"
 
-SRC_URI = \
-    "http://projects.o-hand.com/sources/exmap-console/exmap-console-${PV}.tgz"
+SRC_URI = "http://projects.o-hand.com/sources/exmap-console/exmap-console-${PV}.tgz"
 
 inherit module-base
 inherit autotools
@@ -13,7 +13,7 @@ MYPV := "${PV}"
 
 PACKAGES += "exmap-server kernel-module-exmap"
 
-FILES_${PN}= "${bindir}/exmap ${bindir}/exmapd"
+FILES_exmap-console = "${bindir}/exmap ${bindir}/exmapd"
 PACKAGE_ARCH_exmap-console = "${TARGET_ARCH}"
 RDEPENDS_exmap-console += "kernel-module-exmap"
 
@@ -25,7 +25,6 @@ FILES_kernel-module-exmap = "${base_libdir}"
 PACKAGE_ARCH_kernel-module-exmap = "${MACHINE_ARCH}"
 PV_kernel-module-exmap = "${MYPV}-${KERNEL_VERSION}"
 RDEPENDS_kernel-module-exmap += "kernel (${KERNEL_VERSION})"
-DEPENDS_kernel-module-exmap += "virtual/kernel"
 
 S = "${WORKDIR}/exmap-console-${PV}"
 
diff --git a/meta/packages/exmap-console/exmap-console_0.4.bb b/meta/packages/exmap-console/exmap-console_0.4.bb
new file mode 100644 (file)
index 0000000..ffdded1
--- /dev/null
@@ -0,0 +1 @@
+require exmap-console.inc
\ No newline at end of file
index 9e93847e6dc610c0d545ce3ce05c2041a91f25cc..684ff6aac305a530cec0e6a5f0b5f9cbe34c7ee7 100644 (file)
@@ -1,59 +1,11 @@
-DESCRIPTION = "console-based exmap"
-HOMEPAGE = "http://www.o-hand.com"
-SECTION = "devel"
-LICENSE = "GPL"
-PR = "r10"
+require exmap-console.inc
 
+PR = "r10"
 PV = "0.4+svn${SRCDATE}"
-MYPV := "${PV}"
-
-SRC_URI = \
-    "svn://svn.o-hand.com/repos/misc/trunk;module=exmap-console;proto=http"
 
-inherit module-base
-inherit autotools
-
-PACKAGES += "exmap-server kernel-module-exmap"
-
-FILES_${PN}= "${bindir}/exmap ${bindir}/exmapd"
-PACKAGE_ARCH_exmap-console = "${TARGET_ARCH}"
-RDEPENDS_exmap-console += "kernel-module-exmap"
-
-FILES_exmap-server = "${bindir}/exmapserver"
-PACKAGE_ARCH_exmap-server = "${TARGET_ARCH}"
-RDEPENDS_exmap-server += "kernel-module-exmap"
-
-FILES_kernel-module-exmap = "${base_libdir}"
-PACKAGE_ARCH_kernel-module-exmap = "${MACHINE_ARCH}"
-PV_kernel-module-exmap = "${MYPV}-${KERNEL_VERSION}"
-RDEPENDS_kernel-module-exmap += "kernel (${KERNEL_VERSION})"
-DEPENDS_kernel-module-exmap += "virtual/kernel"
+SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=exmap-console;proto=http"
 
 S = "${WORKDIR}/exmap-console"
 
-export MODULE_PATH="${D}${base_libdir}/modules/${KERNEL_VERSION}"
-
-do_compile() {
-       cd ${S}/src
-       make
-
-       cd ${S}/kernel
-       unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
-       oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR}   \
-                  KERNEL_SRC=${STAGING_KERNEL_DIR}    \
-                  KERNEL_VERSION=${KERNEL_VERSION}    \
-                  CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
-                  ${MAKE_TARGETS}
-}
-
-pkg_postinst_append_kernel-module-exmap () {
-       if [ -n "$D" ]; then
-               exit 1
-       fi
-       depmod -a
-       update-modules || true
-}
-
-pkg_postrm_append_kernel-module-exmap () {
-       update-modules || true
-}
+MYPV := "${PV}"
+PV_kernel-module-exmap = "${MYPV}-${KERNEL_VERSION}"