]> code.ossystems Code Review - openembedded-core.git/commitdiff
libgcc: Explicitly wait for the libc packaging to occur before libgcc packages
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 31 Jan 2011 16:37:32 +0000 (16:37 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 31 Jan 2011 16:37:32 +0000 (16:37 +0000)
libgcc can link against the libc and libc can be dynamically renamed
so we ensure we package after libc. There was code in the gcc core
for this in the ipk case but it wasn't moved as part of the libgcc
split, this change fixes that oversight.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/gcc/gcc-configure-cross.inc
meta/recipes-devtools/gcc/libgcc_4.5.1.bb

index 04a86853584a5489d55a61d3fe895fd29d5bfc56..346d1640d15640af2133f7fd277f0bc9eab3dd6d 100644 (file)
@@ -20,5 +20,3 @@ do_compile_prepend () {
 
 LIBGCCS_VAR = "-lgcc_s"
 LIBGCCS_VAR_avr32 = ""
-
-do_package_write_ipk[depends] += "virtual/libc:do_package"
index a99fdeffd4a3162a759921d0292dd509f503a376..b6cf2685e5194693756b607672c747f800a01316 100644 (file)
@@ -38,5 +38,9 @@ do_install () {
        fi
 }
 
+do_package_write_ipk[depends] += "virtual/libc:do_package"
+do_package_write_deb[depends] += "virtual/libc:do_package"
+do_package_write_rpm[depends] += "virtual/libc:do_package"
+
 BBCLASSEXTEND = "nativesdk"