]> code.ossystems Code Review - openembedded-core.git/commitdiff
syslinux: Various cleanups and add back some missing staging pieces
authorRichard Purdie <richard@openedhand.com>
Mon, 20 Oct 2008 11:58:05 +0000 (11:58 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 20 Oct 2008 11:58:05 +0000 (11:58 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5542 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/syslinux/syslinux-installer-native_3.36.bb
meta/packages/syslinux/syslinux_3.36.bb

index ae5b73afac9219eb40c71d235324b678ac072ea5..88bc37a1d323aca7948a857acbf7eaa9a3eee749 100644 (file)
@@ -1,14 +1,13 @@
-# syslinux-native OE build file
 # Copyright (C) 2004-2006, Advanced Micro Devices, Inc.  All Rights Reserved
 # Released under the MIT license (see packages/COPYING)
 
-DESCRIPTION="A multi-purpose linux bootloader"
-HOMEPAGE="http://syslinux.zytor.com/"
-LICENSE="GPL"
+DESCRIPTION = "A multi-purpose linux bootloader"
+HOMEPAGE = "http://syslinux.zytor.com/"
+LICENSE = "GPL"
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
 
-S="${WORKDIR}/syslinux-${PV}"
-STAGE_TEMP="${WORKDIR}/stage_temp"
+S = "${WORKDIR}/syslinux-${PV}"
+STAGE_TEMP = "${WORKDIR}/stage_temp"
 
 inherit native
 
index 4458c1f234e179b2cc6f5b25babc5bddb88e6978..42880f40762cd5584375c11d425f5af579325af9 100644 (file)
@@ -1,14 +1,31 @@
-DESCRIPTION="A multi-purpose linux bootloader"
-HOMEPAGE="http://syslinux.zytor.com/"
-LICENSE="GPL"
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
+DESCRIPTION = "A multi-purpose linux bootloader"
+HOMEPAGE = "http://syslinux.zytor.com/"
+LICENSE = "GPL"
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2"
+PR = "r1"
 
 # If you really want to run syslinux, you need mtools.  We just want the
 # ldlinux.* stuff for now, so skip mtools-native
-DEPENDS="nasm-native"
+DEPENDS = "nasm-native"
 
-S="${WORKDIR}/syslinux-${PV}"
+S = "${WORKDIR}/syslinux-${PV}"
 
 do_configure() {
        sed -i ${S}/Makefile ${S}/*/Makefile -e 's/\(CC[\t ]*\)=/\1?=/'
 }
+
+STAGE_TEMP = "${WORKDIR}/stage_temp"
+
+do_stage() {
+       install -d ${STAGE_TEMP}
+       oe_runmake install INSTALLROOT="${STAGE_TEMP}"
+       
+       # When building media, the syslinux binary isn't nearly as useful
+       # as the DOS data files, so we copy those into a special location
+       # for usage during a image build stage
+           
+       install -d ${STAGING_DATADIR}/syslinux
+       install -m 0644 ${STAGE_TEMP}/usr/lib/syslinux/isolinux.bin ${STAGING_DATADIR}/syslinux/isolinux.bin
+       install -m 644 ${S}/ldlinux.sys ${STAGING_DATADIR}/syslinux/ldlinux.sys
+       install -m 644 ${S}/ldlinux.bss ${STAGING_DATADIR}/syslinux/ldlinux.bss
+}