]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta-toolchain: provide /usr/ symlink (related to sysroot usage) - requested by Rob
authorMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 18 Dec 2007 08:57:19 +0000 (08:57 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 18 Dec 2007 08:57:19 +0000 (08:57 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3342 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/meta/meta-toolchain.bb

index a093d961c9e472a43cf2319c7c955b50aa34e14c..ab35204c6a5ed7a67798a231a131442719e7b335 100644 (file)
@@ -1,6 +1,7 @@
 DESCRIPTION = "Meta package for building a installable toolchain"
 LICENSE = "MIT"
 DEPENDS = "ipkg-native ipkg-utils-native fakeroot-native sed-native"
+PR = "r1"
 
 inherit sdk meta
 
@@ -98,6 +99,10 @@ do_populate_sdk() {
        # remove broken .la files
        rm -f ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}/lib/*.la
 
+       # /usr/local/poky/eabi-glibc/arm/arm-poky-linux-gnueabi/usr -> .
+       cd ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}
+       ln -sf . usr 
+
         mkdir -p ${SDK_DEPLOY}
        cd ${SDK_OUTPUT}
        fakeroot tar cfj ${SDK_DEPLOY}/${SDK_NAME}-toolchain-${DISTRO_VERSION}.tar.bz2 .