]> code.ossystems Code Review - openembedded-core.git/commitdiff
v86d: mask fbsetup when necessary
authorChen Qi <Qi.Chen@windriver.com>
Wed, 3 Sep 2014 07:09:18 +0000 (15:09 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 3 Sep 2014 09:24:22 +0000 (10:24 +0100)
When 'sysvinit' and 'systemd' are both in DISTRO_FEATURES, we need
to prevent the init script from running via systemd.
This is because that the functionality has been implemented internally
in systemd.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/v86d/v86d_0.1.10.bb

index 7ccb4ee30f839eeea4d4250928afc9099ae9a453..f50207212fb2fb9c7ed90add06a1c411ee3a95cb 100644 (file)
@@ -57,3 +57,13 @@ python __anonymous() {
 }
 
 inherit update-rc.d
+
+DEPENDS_append = " ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd-systemctl-native','',d)}"
+pkg_postinst_${PN} () {
+       if ${@bb.utils.contains('DISTRO_FEATURES','systemd sysvinit','true','false',d)}; then
+               if [ -n "$D" ]; then
+                       OPTS="--root=$D"
+               fi
+               systemctl $OPTS mask fbsetup.service
+       fi
+}