]> code.ossystems Code Review - openembedded-core.git/commitdiff
docbook-utils: Add check to not sed files twice
authorSaul Wold <sgw@linux.intel.com>
Tue, 13 Mar 2012 21:11:56 +0000 (14:11 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 13 Mar 2012 23:16:31 +0000 (23:16 +0000)
This comes about from the code configure code getting run
multiple times on the same WORKDIR and re-sed'ing already
modified files.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb

index c2ccef34299b415b5f25b5c68157ca38881f811d..96459dc26f94b846954a0823c577cadd452c2dda 100644 (file)
@@ -7,7 +7,7 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 DEPENDS = "openjade-native sgmlspl-native docbook-dsssl-stylesheets-native docbook-sgml-dtd-3.1-native"
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/docbook-utils-${PV}.tar.gz"
 
@@ -18,12 +18,15 @@ inherit autotools native
 
 do_configure_prepend() {
        # Fix hard-coded references to /etc/sgml
-       sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" bin/jw.in
-       sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/man/Makefile.am
-       sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/HTML/Makefile.am
-
-       # Point jw to the native sysroot catalog
-       sed -i -e 's|^SGML_EXTRA_CATALOGS=""|SGML_EXTRA_CATALOGS=":${sysconfdir}/sgml/catalog"|g' bin/jw.in
+       if [ ! -e ${WORKDIR}/.sed_done ]; then
+               sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" bin/jw.in
+               sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/man/Makefile.am
+               sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/HTML/Makefile.am
+
+               # Point jw to the native sysroot catalog
+               sed -i -e 's|^SGML_EXTRA_CATALOGS=""|SGML_EXTRA_CATALOGS=":${sysconfdir}/sgml/catalog"|g' bin/jw.in
+               touch ${WORKDIR}/.sed_done
+       fi
 }
 
 do_install() {