]> code.ossystems Code Review - openembedded-core.git/commitdiff
libmusicbrainz: fix type of len variable to get it built
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 1 Aug 2007 20:40:19 +0000 (20:40 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 1 Aug 2007 20:40:19 +0000 (20:40 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2303 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/musicbrainz/files/change-len-type.patch [new file with mode: 0644]
meta/packages/musicbrainz/libmusicbrainz_2.1.2.bb

diff --git a/meta/packages/musicbrainz/files/change-len-type.patch b/meta/packages/musicbrainz/files/change-len-type.patch
new file mode 100644 (file)
index 0000000..b2e6b08
--- /dev/null
@@ -0,0 +1,11 @@
+--- libmusicbrainz-2.1.2.orig/lib/comsocket.cpp
++++ libmusicbrainz-2.1.2/lib/comsocket.cpp
+@@ -356,7 +356,7 @@
+ &wset))
+               {
+                       int error = 0;
+-                        mb_socklen_t len = sizeof(error);
++                        int len = sizeof(error);
+               if (getsockopt(m_nSocket, SOL_SOCKET, SO_ERROR, &error,
+ &len) < 0)
index 43632d86703da8f3bac05b2691b5ec18baacea1b..f26cd34ade1a5f0a49df30598fa14c5774dc5ace 100644 (file)
@@ -2,8 +2,10 @@ DESCRIPTION = "The MusicBrainz client is a library which can be built into other
 HOMEPAGE = "http://musicbrainz.org"
 LICENSE = "LGPL"
 DEPENDS = "expat"
+PR = "r1"
 
-SRC_URI = "http://ftp.musicbrainz.org/pub/musicbrainz/libmusicbrainz-2.1.2.tar.gz"
+SRC_URI = "http://ftp.musicbrainz.org/pub/musicbrainz/libmusicbrainz-2.1.2.tar.gz \
+           file://change-len-type.patch;patch=1"
 
 inherit autotools pkgconfig