]> code.ossystems Code Review - openembedded-core.git/commitdiff
unzip: added 552 from OE - needed for spectrum-fw
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 25 Oct 2007 15:37:04 +0000 (15:37 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 25 Oct 2007 15:37:04 +0000 (15:37 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2981 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/unzip/unzip-native_552.bb [new file with mode: 0644]
meta/packages/unzip/unzip_552.bb [new file with mode: 0644]

diff --git a/meta/packages/unzip/unzip-native_552.bb b/meta/packages/unzip/unzip-native_552.bb
new file mode 100644 (file)
index 0000000..1d4b18c
--- /dev/null
@@ -0,0 +1,8 @@
+SECTION = "console/utils"
+inherit native
+require unzip_${PV}.bb
+
+do_stage() {
+       install -d ${STAGING_BINDIR}
+       install unzip ${STAGING_BINDIR}
+}
diff --git a/meta/packages/unzip/unzip_552.bb b/meta/packages/unzip/unzip_552.bb
new file mode 100644 (file)
index 0000000..2f06e1b
--- /dev/null
@@ -0,0 +1,21 @@
+DESCRIPTION = "A (de)compression library for the ZIP format"
+SECTION = "console/utils"
+LICENSE = "Info-ZIP"
+PR = "r1"
+
+SRC_URI = "http://ftp.info-zip.org/pub/infozip/src/unzip${PV}.tar.gz"
+S = "${WORKDIR}/unzip-5.52"
+
+export LD = "${CC}"
+
+do_compile() {
+        oe_runmake -f unix/Makefile generic
+}
+
+do_install() {
+        oe_runmake -f unix/Makefile install prefix=${D}${prefix}
+       install -d ${D}${mandir}
+       mv ${D}${prefix}/man/* ${D}${mandir}
+}
+
+