]> code.ossystems Code Review - openembedded-core.git/commitdiff
piglit: don't use /tmp to write generated sources to
authorRoss Burton <ross.burton@intel.com>
Tue, 2 Feb 2016 22:42:57 +0000 (22:42 +0000)
committerSaul Wold <sgw@linux.intel.com>
Wed, 3 Feb 2016 17:48:20 +0000 (09:48 -0800)
If there are multiple builds on the same machine then piglit writing it's
generated sources to /tmp will race.  Instead, export TEMP to tell the tempfile
module to use a temporary directory under ${B}.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-graphics/piglit/piglit_git.bb

index 0d825c98186c925f25747050482ad53a183f8b68..55ad78c091c0e962dffdce3d25b9802ad467752c 100644 (file)
@@ -18,6 +18,12 @@ inherit cmake pythonnative distro_features_check
 # depends on virtual/libx11
 REQUIRED_DISTRO_FEATURES = "x11"
 
+# The built scripts go into the temporary directory according to tempfile
+# (typically /tmp) which can race if multiple builds happen on the same machine,
+# so tell it to use a directory in ${B} to avoid overwriting.
+export TEMP = "${B}/temp/"
+do_compile[dirs] =+ "${B}/temp/"
+
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"