]> code.ossystems Code Review - openembedded-core.git/commitdiff
web_svn: make it buildable for world build
authorSaul Wold <sgw@linux.intel.com>
Mon, 15 Nov 2010 22:01:31 +0000 (14:01 -0800)
committerSaul Wold <Saul.Wold@intel.com>
Thu, 18 Nov 2010 21:30:25 +0000 (13:30 -0800)
libowl was missing from the link library list
There where patches being pulled in from the SVN trunk that confused
quilt, so we remove the patches directory before doing the patching
Added LIC_FILES_CHKSUM
Updated LICENSE Metadata

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-sato/web/web/owl-window-menu.patch
meta/recipes-sato/web/web_svn.bb

index 6e60dd08931f6db49c627b5c0cca6826f4f6671e..b80905fce3e02d6be003e37b3ea20eea82af7af7 100644 (file)
@@ -1,7 +1,7 @@
 Index: trunk/src/web_main.c
 ===================================================================
---- trunk.orig/src/web_main.c  2007-04-19 15:41:44.000000000 +0100
-+++ trunk/src/web_main.c       2007-04-26 07:43:23.000000000 +0100
+--- trunk.orig/src/web_main.c  2007-12-18 15:04:13.000000000 -0800
++++ trunk/src/web_main.c       2010-11-15 11:40:44.762994000 -0800
 @@ -20,6 +20,8 @@
  #include "web_bookmarks.h"
  #include "web_request.h"
index 583be4aa24c0a18a78791de79e3fb7fe51df77f8..08005dd2536a69287ba060bc79c3bc351839bd6b 100644 (file)
@@ -1,4 +1,4 @@
-LICENSE = "GPL"
+LICENSE = "GPLv2"
 SECTION = "x11"
 DEPENDS = "libxml2 glib-2.0 gtk+ libglade gtkhtml2 curl gconf js libowl"
 DESCRIPTION = "Web is a multi-platform web browsing application."
@@ -7,10 +7,20 @@ PR = "r2"
 PV = "0.0+svnr${SRCREV}"
 
 SRC_URI =      "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
-               file://owl-window-menu.patch;patch=1 \
+               file://owl-window-menu.patch \
                "
 
+LIB_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
 S = "${WORKDIR}/trunk"
 
+do_unpack_append () {
+       bb.build.exec_func('do_remove_patches', d)
+}
+
+do_remove_patches () {
+       rm -rf ${S}/patches
+}
+
 inherit autotools pkgconfig gconf