]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto: use bareclone option
authorBruce Ashfield <bruce.ashfield@windriver.com>
Tue, 6 Mar 2012 17:03:09 +0000 (09:03 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 8 Mar 2012 19:46:24 +0000 (11:46 -0800)
Instead of specifying nocheckout=1, it provides a better workflow if
the linux-yocto recipes use the new bareclone=1 option to get a mirrored
copy of the source repository. This allows all local and remote branches
to be available during the kernel build and development cycle.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb
meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
meta/recipes-kernel/linux/linux-yocto_3.0.bb
meta/recipes-kernel/linux/linux-yocto_3.2.bb

index 8090535f9e5d0864d1120324a193fe01f1ed16b6..81203005dffeb65effa42430a2a986563e77a948 100644 (file)
@@ -18,10 +18,10 @@ SRCREV_machine ?= "03705f7f066d83b4cd3a6088781d47e3b9e45b71"
 SRCREV_machine_qemuppc ?= "c8b184e8171f6f5a8017be4c5bf1e7a38c3f3002"
 SRCREV_meta ?= "d7b46785d6781e2c23d754f35f09bebd3b74b5bb"
 
-PR = "r1"
+PR = "r2"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
-SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0.git;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
 
 # Omit broken machines from COMPATIBLE_MACHINE
 #   qemuppc hangs at boot
index bbb227fe4f8e224f50f2486c948aa91b3b34c025..e5db5df25324e64583606c5479dfefc4526caf1e 100644 (file)
@@ -19,10 +19,10 @@ SRCREV_machine_qemuppc ?= "470deb222a704f84f3acf3a013a19d2da399d511"
 SRCREV_meta ?= "4c648bbbc7d2204d1b24f444aebb10f91c4ecae3"
 
 
-PR = "r0"
+PR = "r1"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
-SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2.git;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
 
 # Omit broken machines from COMPATIBLE_MACHINE
 #   qemuppc hangs at boot
index 32d502fff959c2ee6292b85e7700915e3d9a890a..61706ea245581a2a669ac1f7b50d28c789ce0d4b 100644 (file)
@@ -10,10 +10,10 @@ LINUX_VERSION ?= "3.0.22"
 SRCREV_machine ?= "c578f3a1f357142a6e02a1df4ae9aa16f45094d6"
 SRCREV_meta ?= "d7b46785d6781e2c23d754f35f09bebd3b74b5bb"
 
-PR = "r1"
+PR = "r2"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
-SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta \
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta \
            file://core.cfg \
            file://serial.cfg \
            file://ext2.cfg \
index 27c7558cb29373100e5cec2567405f5e2ed9e837..d3da75cfc6b1c9a91b43c5b633a32edb1ed96b73 100644 (file)
@@ -20,10 +20,10 @@ SRCREV_machine_qemux86-64 = "af2bfbe5f757361b5b027a24d67a93bfdfaaf33c"
 SRCREV_machine = "4ae8f8605c81c39b959948e23f7123294a5dfb3f"
 SRCREV_meta = "aeea99683c7283f1f3320bf2ee7085ee252d4e7e"
 
-PR = "r22"
+PR = "r23"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
-SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
 
 COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
 
index 58e1f6b17255c66bad1ac1d5385efcf65131e062..819bf70543f9a299611f4c760ebd4eaf1dbeef59 100644 (file)
@@ -20,10 +20,10 @@ SRCREV_machine_qemux86-64 ?= "14fe1742198bd5a85fbcf6e53d336838ff87b2ef"
 SRCREV_machine ?= "c578f3a1f357142a6e02a1df4ae9aa16f45094d6"
 SRCREV_meta ?= "d7b46785d6781e2c23d754f35f09bebd3b74b5bb"
 
-PR = "r3"
+PR = "r4"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
-SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
 
 COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
 
index ecde039193abc95942703c477e897959b2cc890b..bad6f5ed0e7bce73aa657cb27c03feae365dc3c1 100644 (file)
@@ -26,10 +26,10 @@ SRCREV_machine_qemux86-64 ?= "f54af84c64408a0259a919d1fd2405c0115c0a0b"
 SRCREV_machine ?= "21ab5dca134a6bf1316aa59f69f9ee9e091d5702"
 SRCREV_meta ?= "4c648bbbc7d2204d1b24f444aebb10f91c4ecae3"
 
-PR = "r0"
+PR = "r1"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
-SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
 
 COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"