]> code.ossystems Code Review - openembedded-core.git/commitdiff
librsvg: add more PACKAGECONFIG options
authorRoss Burton <ross.burton@intel.com>
Thu, 16 May 2013 16:52:00 +0000 (17:52 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 24 May 2013 13:06:59 +0000 (14:06 +0100)
Add options for the gdk-pixbuf loaders and the GTK+ 2 theme engine.  The theme
engine is generally unused so don't enable that by default, but enable the
gdk-pixbuf loader and also enable the croco feature which is required for
parsing CSS embedded into SVG.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-gnome/librsvg/librsvg_2.32.1.bb

index dcacce4b0078e0550c6d74ca0ea02d98e53e77f3..2bc1624df9556b77e5f235c538e01a7cf6f267a8 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
                     file://rsvg.h;beginline=3;endline=24;md5=20b4113c4909bbf0d67e006778302bc6"
 
 SECTION = "x11/utils"
-DEPENDS = "gtk+ cairo libxml2"
+DEPENDS = "cairo glib-2.0 gdk-pixbuf fontconfig freetype libxml2 pango"
 DEPENDS_class-native = "cairo-native pango-native gdk-pixbuf-native"
 BBCLASSEXTEND = "native"
 
@@ -17,11 +17,14 @@ inherit autotools pkgconfig gnome gtk-doc pixbufcache
 
 EXTRA_OECONF = "--disable-mozilla-plugin --without-svgz"
 
-PACKAGECONFIG ??= "croco"
-# When native we can manage without croco, as it's only for GTK+
-PACKAGECONFIG_class-native = ""
+PACKAGECONFIG ??= "croco gdkpixbuf"
 
+# Support embedded CSS stylesheets (recommended upstream)
 PACKAGECONFIG[croco] = "--with-croco,--without-croco,libcroco"
+# gdk-pixbuf loader
+PACKAGECONFIG[gdkpixbuf] = "--enable-pixbuf-loader,--disable-pixbuf-loader"
+# GTK+ 2 theme engine
+PACKAGECONFIG[gtk] = "--enable-gtk-theme,--disable-gtk-theme,gtk+"
 
 SRC_URI += "file://doc_Makefile.patch \
            file://librsvg-CVE-2011-3146.patch \