]> code.ossystems Code Review - openembedded-core.git/commitdiff
bitbake: cooker.py: Fix the point the configuration __depends is renamed
authorRichard Purdie <richard@openedhand.com>
Wed, 8 Oct 2008 14:02:06 +0000 (14:02 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 8 Oct 2008 14:02:06 +0000 (14:02 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5453 311d38ba-8fff-0310-9ca6-ca027cbcb966

bitbake-dev/lib/bb/cooker.py

index 1531808613d9340a166278c59b0d5fafb2263125..8feb228faf8dc37ebac3da252109402058ee971b 100644 (file)
@@ -762,8 +762,8 @@ class BBCooker:
         self.handleCollections( bb.data.getVar("BBFILE_COLLECTIONS", self.configuration.data, 1) )
 
         bb.msg.debug(1, bb.msg.domain.Collection, "collecting .bb files")
-        bb.data.renameVar("__depends", "__base_depends", self.configuration.data)
         (filelist, masked) = self.collect_bbfiles()
+        bb.data.renameVar("__depends", "__base_depends", self.configuration.data)
         self.parse_bbfiles(filelist, masked)
         bb.msg.debug(1, bb.msg.domain.Collection, "parsing complete")