]> code.ossystems Code Review - openembedded-core.git/commitdiff
dtc: Cleanup and update recipe
authorSaul Wold <sgw@linux.intel.com>
Tue, 24 May 2011 21:55:36 +0000 (14:55 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 1 Jun 2011 17:32:27 +0000 (18:32 +0100)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-kernel/dtc/dtc-native.inc [deleted file]
meta/recipes-kernel/dtc/dtc-native_git.bb [deleted file]
meta/recipes-kernel/dtc/dtc.inc
meta/recipes-kernel/dtc/dtc/remove_space_opt.patch
meta/recipes-kernel/dtc/dtc_git.bb
meta/recipes-kernel/dtc/dtc_git.inc [deleted file]

diff --git a/meta/recipes-kernel/dtc/dtc-native.inc b/meta/recipes-kernel/dtc/dtc-native.inc
deleted file mode 100644 (file)
index 1da7004..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-require dtc.inc
-
-inherit native
diff --git a/meta/recipes-kernel/dtc/dtc-native_git.bb b/meta/recipes-kernel/dtc/dtc-native_git.bb
deleted file mode 100644 (file)
index fd5bde5..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-LIC_FILES_CHKSUM = "file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f \
-                   file://libfdt/libfdt.h;beginline=3;endline=52;md5=fb360963151f8ec2d6c06b055bcbb68c"
-
-require dtc-native.inc
-require dtc_git.inc
index e068df3c73e65f2df77cc2afaead06fb2e479972..cfed15a4c5ad285a9302b7a791c85cbc24e7d588 100644 (file)
@@ -2,7 +2,7 @@ SUMMARY = "Device Tree Compiler"
 DESCRIPTION = "The Device Tree Compiler is a tool used to manipulate the Open-Firmware-like device tree used by PowerPC kernels."
 SECTION = "bootloader"
 PRIORITY = "optional"
-LICENSE = "GPL"
+LICENSE = "GPL2 | BSD"
 DEPENDS = "flex-native bison-native"
 
 inherit autotools
@@ -11,3 +11,9 @@ do_install() {
        install -m 0755 -d ${D}${bindir}
        install -m 755 dtc ${D}${bindir}/dtc
 }
+SRC_URI = "git://www.jdl.com/software/dtc.git;protocol=git \
+       file://fix_for_compilation_with_gcc_4.6.0.patch"
+
+INC_PR = "r0"
+
+S = "${WORKDIR}/git"
index 805bf58796587a411c56c1b20183684b23658dd2..8c26deca354ec59cd907f2356e268bc62b92818d 100644 (file)
@@ -1,5 +1,7 @@
 Remove the -Os flag
 
+Upstream-Status: Inappropriate [configuration]
+
 Signed-off-by: Saul Wold <sgw@linux.intel.com>
 Index: git/Makefile
 ===================================================================
index 1cca32cedb5d7a769db3e8952bd9f9d19eae20c1..e010488dd8048c8d651b746a00b76be3753b9303 100644 (file)
@@ -1,7 +1,16 @@
 require dtc.inc
-require dtc_git.inc
-LICENSE="GPLv2|BSD"
+
 LIC_FILES_CHKSUM = "file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f \
                    file://libfdt/libfdt.h;beginline=3;endline=52;md5=fb360963151f8ec2d6c06b055bcbb68c"
 
-SRC_URI += " file://remove_space_opt.patch"
+SRCREV = "73dca9ae0b9abe6924ba640164ecce9f8df69c5a"
+PV = "1.3.0+git${SRCPV}"
+PR = "${INC_PR}.0"
+
+S = "${WORKDIR}/git"
+
+SRC_URI_PATCH = " file://remove_space_opt.patch"
+SRC_URI_PATCH_virtclass-native = ""
+SRC_URI += "${SRC_URI_PATCH}"
+
+BBCLASSEXTEND = "native"
diff --git a/meta/recipes-kernel/dtc/dtc_git.inc b/meta/recipes-kernel/dtc/dtc_git.inc
deleted file mode 100644 (file)
index 2400cfe..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-SRC_URI = "git://www.jdl.com/software/dtc.git;protocol=git \
-       file://fix_for_compilation_with_gcc_4.6.0.patch"
-
-SRCREV = "73dca9ae0b9abe6924ba640164ecce9f8df69c5a"
-PV = "1.2.0+git${SRCPV}"
-PR = "r3"
-
-S = "${WORKDIR}/git"