]> code.ossystems Code Review - openembedded-core.git/commitdiff
portmap: enable tcp-wrappers support
authorQing He <qing.he@intel.com>
Wed, 11 Aug 2010 02:23:16 +0000 (10:23 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 13 Aug 2010 12:36:03 +0000 (13:36 +0100)
this enables the hosts access control facility (i.e. /etc/hosts.allow
and /etc/hosts.deny)

changes:
  - enable tcp-wrappers by change make flags and cppflags
  - rename patch no-tcpd-support to avoid confusion
  - minor cleanups

Signed-off-by: Qing He <qing.he@intel.com>
meta/packages/portmap/portmap-6.0/tcpd-config.patch [moved from meta/packages/portmap/portmap-6.0/no-tcpd-support.patch with 100% similarity]
meta/packages/portmap/portmap_6.0.bb

index 7f580a767632212a7d9bbb605eb3e99c0543851c..49ac1d8332442baab2dc146e6a06dc741c767a47 100644 (file)
@@ -1,17 +1,16 @@
 require portmap.inc
 
-PR = "r6"
+DEPENDS += "tcp-wrappers"
+PR = "r7"
 
 SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/portmap-6.0.tgz \
-           file://destdir-no-strip.patch;apply=yes \
-           file://no-tcpd-support.patch;apply=yes \
+           file://destdir-no-strip.patch \
+           file://tcpd-config.patch \
            file://portmap.init"
 
-S = "${WORKDIR}/${PN}_${PV}/"
+S = "${WORKDIR}/${BPN}_${PV}/"
 
-EXTRA_OEMAKE_append = " NO_TCP_WRAPPER=1 "
-
-CPPFLAGS += "-DFACILITY=LOG_DAEMON -DENABLE_DNS"
+CPPFLAGS += "-DFACILITY=LOG_DAEMON -DENABLE_DNS -DHOSTS_ACCESS"
 CFLAGS += "-Wall -Wstrict-prototypes -fPIC"
 
 fakeroot do_install() {